source: ProjectBuilder/0.8.5/pbconf/project-builder/rpm/project-builder.spec@ 222

Last change on this file since 222 was 222, checked in by Bruno Cornec, 17 years ago

Fix build issues on suse/fedora
(bz2 on the fly, perl macros)

File size: 1.5 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib: %(eval "`%{__perl} -V:installvendorlib | cut -d= -f2`")
5
6Summary: Project Builder aka pb is a tool to produce packages for multiple distributions
7Summary(fr): Project Builder ou pb est un programme pour produire des paquets pour diverses distributions
8
9Name: PBPKG
10Version: PBVER
11Release: PBTAGPBSUF
12License: GPL
13Group: PBGRP
14Url: http://trac.project-builder.org
15Source: PBSRC
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
17BuildArch: noarch
18Requires: perl >= 5.8.4, perl-DateManip, perl-AppConfig, PBDEP
19Provides: perl(ProjectBuilder::Changelog), perl(ProjectBuilder::Base), perl(ProjectBuilder::Distribution), perl(ProjectBuilder::Version)
20
21%description
22Project Builder aka pb is a tool to produce packages for multiple
23distributions.
24It does that by minimizing the duplication of information required
25and a set a very simple configuration files.
26
27%description -l fr
28Project Builder ou pb est un programme pour produire des paquets pour
29diverses distributions.
30Il réalise cela en minimisant la duplication des informations requises
31et par un jeu de fichiers de configuration très simples.
32
33%prep
34%setup -q
35
36%build
37%{__perl} Makefile.PL destdir=$RPM_BUILD_ROOT
38make
39
40%install
41make pure_install
42
43%clean
44%{__rm} -rf $RPM_BUILD_ROOT
45
46%files
47%defattr(-,root,root)
48%doc ChangeLog svn.log
49%doc INSTALL COPYING README AUTHORS contrib/pbsetupqemu
50
51%{_prefix}/lib/perl5/vendor_perl/*/*
52%{_bindir}/*
53#%{_mandir}/*/*
54
55%changelog
56PBLOG
Note: See TracBrowser for help on using the repository browser.