source: ProjectBuilder/devel/pbconf/project-builder/rpm/project-builder.spec@ 287

Last change on this file since 287 was 287, checked in by Bruno Cornec, 16 years ago
  • Fix build process for new pb functions on changelogs
  • Fix bugs in newproj where project wasn't always used (some fixed pb were remaining)
File size: 1.5 KB
RevLine 
[14]1#
2# $Id$
3#
[283]4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
[14]5
6Summary: Project Builder aka pb is a tool to produce packages for multiple distributions
7Summary(fr): Project Builder ou pb est un programme pour produire des paquets pour diverses distributions
8
[27]9Name: PBPKG
[15]10Version: PBVER
[99]11Release: PBTAGPBSUF
[14]12License: GPL
[15]13Group: PBGRP
[226]14Url: http://trac.project-builder.org
[15]15Source: PBSRC
[14]16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
[25]17BuildArch: noarch
[175]18Requires: perl >= 5.8.4, perl-DateManip, perl-AppConfig, PBDEP
[74]19Provides: perl(ProjectBuilder::Changelog), perl(ProjectBuilder::Base), perl(ProjectBuilder::Distribution), perl(ProjectBuilder::Version)
[14]20
21%description
[154]22Project Builder aka pb is a tool to produce packages for multiple
23distributions.
24It does that by minimizing the duplication of information required
25and a set a very simple configuration files.
[14]26
27%description -l fr
[52]28Project Builder ou pb est un programme pour produire des paquets pour
29diverses distributions.
[154]30Il réalise cela en minimisant la duplication des informations requises
31et par un jeu de fichiers de configuration très simples.
[14]32
33%prep
34%setup -q
35
36%build
[283]37%{__perl} Makefile.PL PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
[203]38make
[14]39
40%install
[283]41%{__rm} -rf $RPM_BUILD_ROOT
42make pure_install
[231]43find ${RPM_BUILD_ROOT} -name perllocal.pod | xargs rm -f
[14]44
45%clean
[226]46%{__rm} -rf $RPM_BUILD_ROOT
[14]47
48%files
49%defattr(-,root,root)
[287]50%doc ChangeLog NEWS AUTHORS
51%doc INSTALL COPYING README contrib/pbsetupqemu
[14]52
[283]53%{perlvendorlib}/*
[226]54%{_bindir}/*
[48]55#%{_mandir}/*/*
[14]56
57%changelog
[17]58PBLOG
Note: See TracBrowser for help on using the repository browser.