source: ProjectBuilder/pbconf/0.10.1/project-builder/rpm/project-builder.spec@ 1168

Last change on this file since 1168 was 1168, checked in by Bruno Cornec, 13 years ago
  • For redhat 7.3 and rhel 2.1 remove the call to %check which doesn't exist and prevents package generation
File size: 1.3 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
5%define srcname PBPKG
6
7Summary: PBSUMMARY
8Summary(fr): Project Builder ou pb produit des paquets pour diverses distributions
9
10Name: PBPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: PBLIC
14Group: PBGRP
15Url: PBURL
16Source: PBREPO/PBSRC
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
18BuildArch: noarch
19Requires: perl >= 5.8.4,perl-DateManip,perl-ProjectBuilder,perl-File-MimeInfo,rpm-build,PBDEP
20
21%description
22PBDESC
23
24%description -l fr
25Project Builder ou pb est un programme pour produire des paquets pour
26diverses distributions.
27Il réalise cela en minimisant la duplication des informations requises
28et par un jeu de fichiers de configuration très simples.
29
30%prep
31%setup -q
32
33%build
34%{__perl} Makefile.PL INSTALLDIRS=vendor PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
35make
36
37%install
38%{__rm} -rf $RPM_BUILD_ROOT
39make DESTDIR=${RPM_BUILD_ROOT} install
40find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -o -name .packlist -o -name '*.bs' -a -size 0 | xargs rm -f
41find ${RPM_BUILD_ROOT} -type d -depth | xargs rmdir --ignore-fail-on-non-empty
42
43PBMKTEST
44
45%clean
46%{__rm} -rf $RPM_BUILD_ROOT
47
48%files
49%defattr(-,root,root)
50%doc NEWS AUTHORS
51%doc INSTALL COPYING README
52
53%{perlvendorlib}/*
54%{_bindir}/*
55%{_mandir}/man1/*
56%{_mandir}/man3/*
57
58%changelog
59PBLOG
Note: See TracBrowser for help on using the repository browser.