source: ProjectBuilder/pbconf/devel/ProjectBuilder/ebuild/ProjectBuilder.ebuild@ 2112

Last change on this file since 2112 was 2112, checked in by Bruno Cornec, 8 years ago
  • Fix ebuilds (No usage of PBSRC as spec specific and EAP reviewed)
  • Fix pbcl using now future version directly
File size: 705 bytes
Line 
1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4# Contributed by Joachim Langenbach <joachim_at_falaba.de>
5
6EAPI=5
7inherit perl-module
8
9PN="PBPKG"
10DESCRIPTION="PBSUMMARY"
11HOMEPAGE="PBURL"
12SRC_URI="PBREPO/PBPKG-PBVER"
13
14LICENSE="GPL-2"
15SLOT="0"
16KEYWORDS="~amd64 ~x86"
17IUSE=""
18
19DEPEND="${RDEPEND}"
20RDEPEND="dev-perl/File-MimeInfo
21 dev-perl/Mail-Sendmail"
22# Targets for pb
23CONFDIR="/etc/pb"
24MANDIR="/usr/share/man"
25
26S=${WORKDIR}/${PN}-${PV}
27
28src_unpack() {
29 unpack ${A}
30 cd "${S}"
31}
32
33#src_install() {
34# dobin bin/*
35# insinto /usr/lib/perl5/site_perl/5.8.8/ProjectBuilder
36# doins lib/ProjectBuilder/*
37# insinto etc
38# doins etc/*
39#}
Note: See TracBrowser for help on using the repository browser.