source: ProjectBuilder/pbconf/devel/ProjectBuilder/ebuild/ProjectBuilder.ebuild@ 2136

Last change on this file since 2136 was 2136, checked in by Bruno Cornec, 8 years ago

Fix #115

The standard conf file is now under /usr/share/pb and the one under
/etc/pn is modifyable by the sysadmin is contains only comments by
default.

File size: 732 bytes
Line 
1# Copyright 1999-2010 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4# Contributed by Joachim Langenbach <joachim_at_falaba.de>
5
6EAPI=5
7inherit perl-module
8
9PN="PBPKG"
10DESCRIPTION="PBSUMMARY"
11HOMEPAGE="PBURL"
12SRC_URI="PBREPO/PBPKG-PBVER"
13
14LICENSE="GPL-2"
15SLOT="0"
16KEYWORDS="~amd64 ~x86"
17IUSE=""
18
19DEPEND="${RDEPEND}"
20RDEPEND="dev-perl/File-MimeInfo
21 dev-perl/Mail-Sendmail"
22# Targets for pb
23CONFDIR="/usr/share/pb"
24SYSCONFDIR="/etc/pb"
25MANDIR="/usr/share/man"
26
27S=${WORKDIR}/${PN}-${PV}
28
29src_unpack() {
30 unpack ${A}
31 cd "${S}"
32}
33
34#src_install() {
35# dobin bin/*
36# insinto /usr/lib/perl5/site_perl/5.8.8/ProjectBuilder
37# doins lib/ProjectBuilder/*
38# insinto etc
39# doins etc/*
40#}
Note: See TracBrowser for help on using the repository browser.