source: ProjectBuilder/pbconf/devel/ProjectBuilder/rpm/perl-ProjectBuilder.spec@ 624

Last change on this file since 624 was 624, checked in by Bruno Cornec, 15 years ago
  • Fix Project-Builder for perl 5.10 build where .packlist file is generated
File size: 1.3 KB
RevLine 
[14]1#
2# $Id$
3#
[283]4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
[541]5%define srcname PBPKG
[14]6
[461]7Summary: Perl module providing support and deal with Linux distributions
8Summary(fr): Module Perl fournissant des fonctions de support et aidant à traiter de diverses distributions Linux
[14]9
[541]10Name: PBREALPKG
[15]11Version: PBVER
[99]12Release: PBTAGPBSUF
[14]13License: GPL
[15]14Group: PBGRP
[226]15Url: http://trac.project-builder.org
[429]16Source: PBREPO/PBSRC
[541]17BuildRoot: %{_tmppath}/%{srcname}-%{version}-%{release}-root-%(id -u -n)
[25]18BuildArch: noarch
[404]19Requires: perl >= 5.8.4, PBDEP
[14]20
21%description
[461]22PBDESC
[14]23
24%description -l fr
[541]25PBREALPKG est un ensemble de fonctions pour aider à développer des projets perl et à traiter de diverses distributions Linux.
[14]26
27%prep
[541]28%setup -q -n %{srcname}-%{version}
[14]29
30%build
[359]31%{__perl} Makefile.PL INSTALLDIRS=vendor PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
[203]32make
[14]33
34%install
[283]35%{__rm} -rf $RPM_BUILD_ROOT
[359]36make DESTDIR=${RPM_BUILD_ROOT} install
[624]37find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -o -name .packlist -o -name '*.bs' -a -size 0 | xargs rm -f
38find ${RPM_BUILD_ROOT} -type d -depth | xargs rmdir --ignore-fail-on-non-empty
[14]39
[359]40%check
41make test
42
[14]43%clean
[226]44%{__rm} -rf $RPM_BUILD_ROOT
[14]45
46%files
47%defattr(-,root,root)
[297]48%doc NEWS AUTHORS
[404]49%doc INSTALL COPYING README
[14]50
[359]51%{perlvendorlib}/*
[226]52%{_bindir}/*
[404]53#%{_mandir}/man1/*
[391]54%{_mandir}/man3/*
[14]55
56%changelog
[17]57PBLOG
Note: See TracBrowser for help on using the repository browser.