source: ProjectBuilder/pbconf/devel/project-builder/rpm/project-builder.spec

Last change on this file was 2683, checked in by Bruno Cornec, 21 months ago

Fix some build deps for perl tests and usage and a wrong macro

File size: 1.7 KB
RevLine 
[14]1#
2# $Id$
3#
[1654]4%define perlvendorlib %(eval "`PBPERLCMD -V:installvendorlib`"; echo $installvendorlib)
[559]5%define srcname PBPKG
[14]6
[27]7Name: PBPKG
[15]8Version: PBVER
[99]9Release: PBTAGPBSUF
[2083]10Summary: PBSUMMARY
11Summary(fr): Project Builder ou pb produit des paquets pour diverses distributions
[1150]12License: PBLIC
[15]13Group: PBGRP
[889]14Url: PBURL
[429]15Source: PBREPO/PBSRC
[14]16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
[2364]17Requires: perl >= 5.6.2,perl-Date-Manip,perl-ProjectBuilder,perl-File-MimeInfo,PBDEP
18# If we want to run make test, we need these modules, but upstream we do tests for this one in another way
19# also pb itself doesn't support using packages at the same time they are built yet
20# see http://trac.project-builder.org/ticket/175
21#BuildRequires: perl-Date-Manip,perl-ProjectBuilder,perl-File-MimeInfo
[1654]22PBBUILDARCH: noarch
[1832]23PBBUILDDEP
[14]24
25%description
[461]26PBDESC
[14]27
28%description -l fr
[52]29Project Builder ou pb est un programme pour produire des paquets pour
30diverses distributions.
[154]31Il réalise cela en minimisant la duplication des informations requises
32et par un jeu de fichiers de configuration très simples.
[14]33
34%prep
[2100]35%setup -q -n %{srcname}-%{version}PBEXTDIR
[14]36
37%build
[1654]38PBPERLCMD Makefile.PL INSTALLDIRS=vendor PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
[203]39make
[14]40
41%install
[283]42%{__rm} -rf $RPM_BUILD_ROOT
[359]43make DESTDIR=${RPM_BUILD_ROOT} install
[624]44find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -o -name .packlist -o -name '*.bs' -a -size 0 | xargs rm -f
45find ${RPM_BUILD_ROOT} -type d -depth | xargs rmdir --ignore-fail-on-non-empty
[14]46
[2364]47#check
48#make test
[2083]49
[14]50%clean
[226]51%{__rm} -rf $RPM_BUILD_ROOT
[14]52
53%files
54%defattr(-,root,root)
[2083]55%doc NEWS AUTHORS COPYING README
[2683]56%{perlvendorlib}/ProjectBuilder/
[2083]57%{_bindir}/pb*
[359]58%{_mandir}/man1/*
[407]59%{_mandir}/man3/*
[14]60
61%changelog
[17]62PBLOG
Note: See TracBrowser for help on using the repository browser.