source: ProjectBuilder/projects/fossology/pbconf/trunk/fossology/rpm/fossology.spec@ 602

Last change on this file since 602 was 602, checked in by Bruno Cornec, 16 years ago

First pass on INSTALL instructions of fossology to fill conf files for pb. Doesn't work. Done as a backup

File size: 3.5 KB
Line 
1#
2# $Id$
3#
4# Used if virtual name != real name (perl, ...)
5#%define srcname PBPKG
6
7Summary: FOSSology is a licenses exploration tool
8Summary(fr): FOSSology est un outil d'exploration de licenses
9
10Name: PBREALPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: PBLIC
14Group: PBGRP
15Url: PBURL
16Source: PBREPO/PBSRC
17#PBPATCHSRC
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
19Requires: postgresql php php-pear php-pgsql file-libs libxml2 binutils bzip2 cpio mkisofs poppler-utils rpm tar unzip gzip httpd PBDEP
20BuildRequires: postgresql-devel file-libs libxml2 gcc make perl PBBUILDDEP
21
22%description
23PBDESC
24
25%description -l fr
26FOSSology est un outil d'exploration de licenses
27
28%prep
29%setup -q
30#PBPATCHCMD
31
32%build
33make %{?_smp_mflags}
34
35%install
36%{__rm} -rf $RPM_BUILD_ROOT
37make DESTDIR=$RPM_BUILD_ROOT install
38cat > $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/fossology.conf << EOF
39Alias /repo/ /usr/share/fossology/www/
40<Directory "/usr/share/fossology/www">
41 AllowOverride None
42 Options FollowSymLinks MultiViews
43 Order allow,deny
44 Allow from all
45 # uncomment to turn on php error reporting
46 #php_flag display_errors on
47 #php_value error_reporting 2039
48</Directory>
49EOF
50
51%clean
52%{__rm} -rf $RPM_BUILD_ROOT
53
54%files
55%defattr(-,root,root)
56%doc ChangeLog
57%doc INSTALL COPYING README AUTHORS NEWS
58
59%post
60# Adjust the kernel shmmax (described in detail in section 2.1.3)
61echo 512000000 > /proc/sys/kernel/shmmax
62grep -q kernel.shmmax /etc/sysctl.conf
63if [ $? -eq 0 ]; then
64 perl -pi -e "s/kernel.shmmax\s*=.*/kernel.shmmax=512000000/" /etc/sysctl.conf
65else
66 echo "kernel.shmmax=512000000" >> /etc/sysctl.conf
67fi
68# Adjust postgresql config (described in detail in section 2.1.4)
69266 > #hba_file = 'ConfigDir/pg_hba.conf' # host-based authentication file
70 267 > #ident_file = 'ConfigDir/pg_ident.conf' # IDENT configuration file
71 268 > #external_pid_file = '(none)' # write an extra pid file
72 269 > listen_addresses = '*'
73 270 > max_connections = 50
74 271 > #shared_buffers = 1000 # min 16 or max_connections*2, 8KB each
75 272 > shared_buffers = 32768
76 273 > work_mem = 10240
77 274 > max_fsm_pages = 100000 # min max_fsm_relations*16, 6 bytes each
78 275 > fsync = off
79 276 > full_page_writes = off #recover from partial page writes
80 277 > commit_delay = 1000
81 278 > effective_cache_size = 25000
82 279 > log_min_duration_statement = -1 # -1 is disabled, 0 logs all statements
83 280 > #log_line_prefix = '' # Special values:
84
85# Adjust PHP config (described in detail in section 2.1.5)
86# /etc/php5/php.ini
87 291 max_execution_time = 90
88 292 memory_limit = 128M
89 293 error_reporting = E_ALL & E_STRICT
90 294 display_startup_errors = On
91 295 log_errors = On
92 296 log_errors_max_len = 0
93 297 error_log = /var/log/php5.log
94 298 post_max_size = 700M
95 299 upload_max_filesize = 701M
96 300 In the "[soap]" section add
97 301 extension=pgsql.so
98 303 You should also edit /etc/php5/cli/php.ini to include the fossology directory
99 304 in the php command line interface path:
100 305 include_path = ".:/usr/local/share/fossology/php:/usr/local/share/fossology/www"
101
102# Add apache config for fossology (described in detail in section 2.1.6) - done in install
103/etc/init.d/httpd reload
104
105# Run the postinstall script
106/usr/lib/fossology/fo-postinstall
107
108# Test that things are installed correctly
109/usr/lib/fossology/fossology-scheduler -t
110if [ $? -ne 0 ]; then
111 exit -1
112fi
113
114chkconfig --add fossology
115/etc/init.d/fossology start
116
117%changelog
118PBLOG
119
Note: See TracBrowser for help on using the repository browser.