source: ProjectBuilder/projects/linuxcoe/pbconf/cvs/linuxcoe-sd-base/rpm/linuxcoe-sd-base.spec@ 759

Last change on this file since 759 was 759, checked in by Bruno Cornec, 15 years ago
  • Fix owner for cache and log dir (webuser and not root to allow cgi scripts to create files in them)
File size: 2.2 KB
Line 
1Name: PBPKG
2Version: PBVER
3Release: PBTAGPBSUF
4Summary: LinuxCOE SystemDesigner web interface
5
6Group: PBGRP
7License: GPL
8URL: http://linuxcoe.sourceforge.net/
9Source: PBSRC
10BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
11
12BuildArch: noarch
13#BuildRequires: ??
14Requires: PBDEP
15Provides: PBPROVIDE
16
17%description
18LinuxCOE SystemDesigner is a unifying web application that allows
19a user to repeatably install, configure, and maintain different
20Linux system installations. It's CGI-based interface provides means
21to generate boot images for network or local media based installations,
22save profiles that store custom installation preferences for later re-use,
23and retrofit already deployed systems by overlaying other value-add components.
24
25%prep
26
27%setup -q
28
29%build
30./configure \
31 webalias="PBwebalias" \
32 webworkdir="PBwebworkdir" \
33 httpdcfgdir="PBhttpdcfgdir" \
34 httpd_user="PBhttpd_user" \
35 httpd_group="PBhttpd_group" \
36 sudoers_cfg="PBsudoers_cfg" \
37 --prefix=PBprefix \
38 --sysconfdir=PBsysconfdir \
39 --localstatedir=%{_var} \
40 --without-MKISOFS \
41 --without-PERLMOD \
42 --without-PALO \
43 --without-SENDMAIL \
44 --without-APACHECTL \
45 --without-SUDO
46
47%install
48%{__rm} -rf $RPM_BUILD_ROOT
49make DESTDIR=$RPM_BUILD_ROOT install
50
51# scriptlets
52
53%clean
54%{__rm} -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(-,root,root,-)
58%config(noreplace) PBsysconfdir/linuxcoe.rc
59%config(noreplace) PBsysconfdir/includes/LinuxCOE-SystemDesigner.conf
60%config(noreplace) PBsysconfdir/includes/config.state
61%config(noreplace) PBsysconfdir/includes/sudoers
62%config(noreplace) %{_sysconfdir}/logrotate.d/LinuxCOE-SystemDesigner
63%doc AUTHORS ChangeLog COPYING INSTALL NEWS README
64%attr(-,PBhttpd_user,PBhttpd_group) %{_var}/cache/PBPROVIDE
65%{_var}/lib/PBPROVIDE
66%attr(-,PBhttpd_user,PBhttpd_group) %{_var}/log/PBPROVIDE
67PBprefix
68
69%post
70# We should add a link so that Apache finds the new conf file
71ln -sf PBsysconfdir/includes/LinuxCOE-SystemDesigner.conf /etc/httpd/conf.d
72
73# httpd
74LANGUAGE=C /etc/init.d/httpd status 2>&1 | grep -q stop
75if [ $? -eq 0 ]; then
76 /etc/init.d/httpd start
77else
78 /etc/init.d/httpd reload
79fi
80chkconfig --add httpd
81
82%changelog
83PBLOG
Note: See TracBrowser for help on using the repository browser.