source: ProjectBuilder/projects/mondorescue/pbconf/branches/2.2.9/mindi/ebuild/mindi.ebuild@ 1202

Last change on this file since 1202 was 1202, checked in by Bruno Cornec, 13 years ago
  • USR_SRC for gentoo should contain the src subdir as we do not use the PBSRC macro
File size: 1.2 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7DESCRIPTION="PBSUMMARY"
8HOMEPAGE="PBURL"
9SRC_URI="PBREPO/src/${P}.tar.gz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="~x86 ~ia64 ~amd64 -*"
14IUSE=""
15
16DEPEND="virtual/libc"
17RDEPEND=">=app-arch/bzip2-0.9
18 sys-libs/ncurses
19 sys-devel/binutils
20 sys-fs/dosfstools
21 sys-apps/mindi-busybox
22 sys-block/parted
23 sys-apps/gawk"
24
25src_unpack() {
26 unpack ${A} || die "Failed to unpack ${A}"
27}
28
29src_install() {
30 export HEAD="${D}"
31 export PREFIX="/usr"
32 export CONFDIR="/etc"
33 export CACHEDIR="/var/cache/mindi"
34 export MANDIR="${PREFIX}/share/man"
35 export DOCDIR="${PREFIX}/share/doc"
36 export LIBDIR="${PREFIX}/lib"
37 export DONT_RELINK=1
38 export PKGBUILDMINDI="true"
39 "${WORKDIR}"/"${P}"/install.sh
40}
41
42pkg_postinst() {
43 einfo "${P} was successfully installed."
44 einfo "Please read the associated docs for help."
45 einfo "Or visit the website @ ${HOMEPAGE}"
46 echo
47 ewarn "This package is still in unstable."
48 ewarn "Please report bugs to http://bugs.gentoo.org/"
49 ewarn "However, please do an advanced query to search for bugs"
50 ewarn "before reporting. This will keep down on duplicates."
51 echo
52}
Note: See TracBrowser for help on using the repository browser.