source: ProjectBuilder/projects/mondorescue/pbconf/branches/3.2/mindi/rpm/mindi.spec@ 2115

Last change on this file since 2115 was 2115, checked in by Bruno Cornec, 8 years ago

Adapt MondoRescue to pb 0.14.x usage with new naming

File size: 1.4 KB
Line 
1#
2# $Id$
3#
4# Avoids to generate debug packages
5%global debug_package %{nil}
6%define srcname PBPKG
7
8Summary: PBSUMMARY
9Name: PBPKG
10Version: PBVER
11Release: PBTAGPBSUF
12License: PBLIC
13Group: PBGRP
14Url: PBURL
15Source: PBREPO/PBSRC
16# Not yet possible as busybox is a binary that should go alongside
17# BuildArch: noarch
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
19Requires: bash
20Requires: bzip2 >= 0.9
21Requires: mkisofs
22Requires: ncurses
23Requires: binutils
24Requires: gawk
25Requires: dosfstools
26Requires: mindi-busybox >= 1.21.1
27Requires: parted
28Requires: perl-MondoRescue
29Requires: mtools
30Requires: syslinux
31Requires: perl-Module-ScanDeps
32Requires: perl-IO-Interface,PBDEP
33ExcludeArch: ppc
34PBOBS
35# Not on all systems
36#Conflicts: bonnie++
37
38%description
39PBDESC
40
41%prep
42%setup -q -n %{name}-%{version}PBEXTDIR
43
44%build
45
46%install
47rm -rf $RPM_BUILD_ROOT
48export DONT_RELINK=1
49
50export HEAD=${RPM_BUILD_ROOT}
51export PREFIX=%{_exec_prefix}
52export CONFDIR=%{_sysconfdir}
53export MANDIR=%{_mandir}
54export SBINDIR=%{_sbindir}
55#export DOCDIR=%{_docdir}
56export LIBDIR=%{_libdir}
57export CACHEDIR=%{_var}/cache/%{name}
58export PKGBUILDMINDI="true"
59
60./install.sh
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(-,root,root)
67%config(noreplace) %{_sysconfdir}/%{name}
68%doc ChangeLog COPYING README TODO README.* NEWS
69#svn.log
70%{_mandir}/man8/*
71%{_libdir}/%{name}
72%{_sbindir}/*
73%{_var}/cache/%{name}
74
75%changelog
76PBLOG
Note: See TracBrowser for help on using the repository browser.