source: ProjectBuilder/projects/mondorescue/pbconf/branches/3.3/mindi-busybox/rpm/mindi-busybox.spec@ 2660

Last change on this file since 2660 was 2660, checked in by Bruno Cornec, 3 years ago

Fixes to allow compilation on Fedora 33

File size: 869 bytes
Line 
1#
2# $Id$
3#
4%define srcname PBPKG
5
6Summary: PBSUMMARY
7Name: PBPKG
8Version: PBVER
9Release: PBTAGPBSUF
10License: GPLv2
11Group: PBGRP
12Url: PBURL
13Source: PBREPO/PBSRC
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
15PBBUILDREQ
16# Cf: https://bugzilla.redhat.com/show_bug.cgi?id=588550
17ExcludeArch: ppc
18# Avoids to generate debug packages
19%global debug_package %{nil}
20PBPATCHSRC
21
22%description
23PBDESC
24
25%prep
26%setup -q -n %{name}-%{version}PBEXTDIR
27PBPATCHCMD
28
29%build
30make oldconfig
31make busybox
32
33%install
34rm -rf $RPM_BUILD_ROOT
35
36export DESTDIR=${RPM_BUILD_ROOT}%{_libdir}/mindi/rootfs
37make CONFIG_PREFIX=$DESTDIR install
38# Make it compatible with latest crazy /bin removal
39./mondo-install.sh
40
41%clean
42rm -rf $RPM_BUILD_ROOT
43
44%files
45%defattr(-,root,root)
46%doc ChangeLog LICENSE AUTHORS README TODO NEWS
47#svn.log
48%{_libdir}/mindi/rootfs
49
50%changelog
51PBLOG
Note: See TracBrowser for help on using the repository browser.