source: ProjectBuilder/projects/mondorescue/pbconf/branches/3.3/mindi/rpm/mindi.spec@ 2346

Last change on this file since 2346 was 2346, checked in by Bruno Cornec, 6 years ago

Fix dependencies and arch:

  • mindi requires either syslinux or elilo
  • mondo deosn't require syslinux by itself
  • fix allowaed archs instead of excluding some
File size: 1.5 KB
RevLine 
[384]1#
[2115]2# $Id$
[384]3#
[2064]4# Avoids to generate debug packages
5%global debug_package %{nil}
[2115]6%define srcname PBPKG
[2064]7
[1199]8Summary: PBSUMMARY
[384]9Name: PBPKG
10Version: PBVER
11Release: PBTAGPBSUF
[488]12License: PBLIC
[384]13Group: PBGRP
[488]14Url: PBURL
[429]15Source: PBREPO/PBSRC
[384]16# Not yet possible as busybox is a binary that should go alongside
17# BuildArch: noarch
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
[2082]19Requires: bash
20Requires: bzip2 >= 0.9
[2240]21Requires: e2fsprogs
[2082]22Requires: ncurses
23Requires: binutils
24Requires: gawk
25Requires: dosfstools
26Requires: mindi-busybox >= 1.21.1
27Requires: parted
[2280]28Requires: which
29Requires: grep >= 2.5
[2082]30Requires: perl-MondoRescue
31Requires: mtools
[2346]32%ifarch ia64
33Requires: elilo
34%else
35Requires: syslinux >= 1.52
36%endif
[2342]37Requires: perl-Module-ScanDeps,PBDEP
[2346]38ExclusiveArch: x86_64 i586 i386 i686 ia64
[384]39PBOBS
40# Not on all systems
41#Conflicts: bonnie++
42
43%description
[1199]44PBDESC
[384]45
46%prep
[2115]47%setup -q -n %{name}-%{version}PBEXTDIR
[384]48
49%build
50
51%install
[488]52rm -rf $RPM_BUILD_ROOT
[384]53export DONT_RELINK=1
54
55export HEAD=${RPM_BUILD_ROOT}
56export PREFIX=%{_exec_prefix}
57export CONFDIR=%{_sysconfdir}
58export MANDIR=%{_mandir}
[1806]59export SBINDIR=%{_sbindir}
[384]60#export DOCDIR=%{_docdir}
61export LIBDIR=%{_libdir}
62export CACHEDIR=%{_var}/cache/%{name}
63export PKGBUILDMINDI="true"
64
65./install.sh
66
67%clean
[488]68rm -rf $RPM_BUILD_ROOT
[384]69
70%files
71%defattr(-,root,root)
72%config(noreplace) %{_sysconfdir}/%{name}
[1770]73%doc ChangeLog COPYING README TODO README.* NEWS
[384]74#svn.log
75%{_mandir}/man8/*
76%{_libdir}/%{name}
77%{_sbindir}/*
78%{_var}/cache/%{name}
79
80%changelog
81PBLOG
Note: See TracBrowser for help on using the repository browser.