source: ProjectBuilder/projects/python-formats/pbconf/python-formats/rpm/python-formats.spec@ 2407

Last change on this file since 2407 was 2407, checked in by Bruno Cornec, 5 years ago

Adds project python-formats to build farm

File size: 1.2 KB
Line 
1#
2# $Id$
3#
4# Used if virtual name != real name (perl, ...) - replace PBPKG by PBREALPKG in the line below
5%define srcname PBPKG
6%define py3 PBPY3
7
8Summary: PBSUMMARY
9
10Name: PBREALPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: PBLIC
14Group: PBGRP
15Url: PBURL
16Source: PBREPO/PBSRC
17BuildArch: noarch
18#PBPATCHSRC
19Requires: PBDEP
20BuildRequires: PBBDEP
21
22%description
23PBDESC
24python2 version
25
26%if %py3
27%package -n python3-PBREALPKG
28Summary: %{summary} / Python 3 library
29Requires: python3-PBREALPKG
30BuildRequires: python3-setuptools
31
32%description -n python3-PBREALPKG
33PBDESC
34python3 version
35%endif
36
37%prep
38%setup -q -n %{srcname}-%{version}PBEXTDIR
39%if %py3
40cd ..
41cp -fr %{srcname}-%{version}PBEXTDIR python3
42cd -
43%endif
44#PBPATCHCMD
45
46%build
47%{__python} setup.py build
48%if %py3
49cd ../python3
50%{__python3} setup.py build
51cd -
52%endif
53
54%install
55%{__rm} -rf %{buildroot}
56%{__python} setup.py install -O1 --skip-build --root %{buildroot}
57%if %py3
58cd ../python3
59%{__python3} setup.py install -O1 --skip-build --root %{buildroot}
60cd -
61%endif
62
63%files
64%doc README.rst
65%{python_sitelib}/*
66
67%if %py3
68%files -n python3-PBREALPKG
69%doc README.rst
70%{python3_sitelib}/*
71%endif
72
73%changelog
74PBLOG
75
76
Note: See TracBrowser for help on using the repository browser.