source: ProjectBuilder/devel/pbconf/project-builder/rpm/pb.spec@ 35

Last change on this file since 35 was 35, checked in by Bruno Cornec, 17 years ago

add perl specifics to spec file

File size: 1.5 KB
Line 
1#
2# $Id$
3#
4
5Summary: Project Builder aka pb is a tool to produce packages for multiple distributions
6Summary(fr): Project Builder ou pb est un programme pour produire des paquets pour diverses distributions
7
8Name: PBPKG
9Version: PBVER
10Release: PBTAG
11License: GPL
12Group: PBGRP
13Url: http://www.mondorescue.org
14Source: PBSRC
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
16BuildArch: noarch
17Requires: perl >= 5.8.4, PBDEP
18
19%description
20Project Builder aka pb is a tool to produce packages for multiple distributions.
21It does that by minimizing the duplication of information required and a set a
22very simple configuration files.
23
24%description -l fr
25Project Builder ou pb est un programme pour produire des paquets pour diverses distributions.
26Il réalise cela en minimisant la duplication des informations requises et par un jeu de
27fichiers de configuration très simples.
28
29%prep
30%setup -q
31
32%build
33%{__rm} -rf $RPM_BUILD_ROOT
34%{__perl} Makefile.PL %{prefix}
35make OPTIMIZE="$RPM_OPT_FLAGS" PREFIX=%{prefix} %{?_smp_mflags} VERSION=%{version}
36#perl -p -i -e 's|/usr/local/bin|/usr/bin|g;' *.pm examples/*
37
38%install
39eval `perl '-V:installarchlib'`
40mkdir -p $RPM_BUILD_ROOT/$installarchlib
41make install PREFIX=$RPM_BUILD_ROOT/%{prefix}
42
43%clean
44%{__rm} -rf $RPM_BUILD_ROOT
45
46%files
47%defattr(-,root,root)
48%config(noreplace) %{_sysconfdir}/%{name}/%{name}.pb
49%doc ChangeLog svn.log
50%doc INSTALL COPYING README TODO AUTHORS NEWS
51
52%{_libdir}/perl5/site_perl/*
53%{_bindir}/*
54#%{_mandir}/man8/*
55
56%changelog
57PBLOG
Note: See TracBrowser for help on using the repository browser.