source: ProjectBuilder/pbconf/devel/ProjectBuilder/rpm/perl-ProjectBuilder.spec@ 541

Last change on this file since 541 was 541, checked in by Bruno Cornec, 16 years ago

Working on the correct .deb generation for virtual/real packages

File size: 1.2 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
5%define srcname PBPKG
6
7Summary: Perl module providing support and deal with Linux distributions
8Summary(fr): Module Perl fournissant des fonctions de support et aidant à traiter de diverses distributions Linux
9
10Name: PBREALPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: GPL
14Group: PBGRP
15Url: http://trac.project-builder.org
16Source: PBREPO/PBSRC
17BuildRoot: %{_tmppath}/%{srcname}-%{version}-%{release}-root-%(id -u -n)
18BuildArch: noarch
19Requires: perl >= 5.8.4, PBDEP
20
21%description
22PBDESC
23
24%description -l fr
25PBREALPKG est un ensemble de fonctions pour aider à développer des projets perl et à traiter de diverses distributions Linux.
26
27%prep
28%setup -q -n %{srcname}-%{version}
29
30%build
31%{__perl} Makefile.PL INSTALLDIRS=vendor PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
32make
33
34%install
35%{__rm} -rf $RPM_BUILD_ROOT
36make DESTDIR=${RPM_BUILD_ROOT} install
37find ${RPM_BUILD_ROOT} -name perllocal.pod | xargs rm -f
38
39%check
40make test
41
42%clean
43%{__rm} -rf $RPM_BUILD_ROOT
44
45%files
46%defattr(-,root,root)
47%doc NEWS AUTHORS
48%doc INSTALL COPYING README
49
50%{perlvendorlib}/*
51%{_bindir}/*
52#%{_mandir}/man1/*
53%{_mandir}/man3/*
54
55%changelog
56PBLOG
Note: See TracBrowser for help on using the repository browser.