source: ProjectBuilder/pbconf/devel/ProjectBuilder/rpm/perl-ProjectBuilder.spec@ 637

Last change on this file since 637 was 637, checked in by Bruno Cornec, 15 years ago
  • Fix rpmlint warnings
  • Adapt for 0.9.5 of pb the pbcl
File size: 1.3 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
5%define srcname PBPKG
6
7Summary: Perl module providing support and deal with Linux distributions
8Summary(fr): Module Perl pour le support de diverses distributions Linux
9
10Name: PBREALPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: GPL
14Group: PBGRP
15Url: http://trac.project-builder.org
16Source: PBREPO/PBSRC
17BuildRoot: %{_tmppath}/%{srcname}-%{version}-%{release}-root-%(id -u -n)
18BuildArch: noarch
19Requires: perl >= 5.8.4, PBDEP
20
21%description
22PBDESC
23
24%description -l fr
25PBREALPKG est un ensemble de fonctions pour aider à développer des projets perl
26et à traiter de diverses distributions Linux.
27
28%prep
29%setup -q -n %{srcname}-%{version}
30
31%build
32%{__perl} Makefile.PL INSTALLDIRS=vendor PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
33make
34
35%install
36%{__rm} -rf $RPM_BUILD_ROOT
37make DESTDIR=${RPM_BUILD_ROOT} install
38find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -o -name .packlist -o -name '*.bs' -a -size 0 | xargs rm -f
39find ${RPM_BUILD_ROOT} -type d -depth | xargs rmdir --ignore-fail-on-non-empty
40
41%check
42make test
43
44%clean
45%{__rm} -rf $RPM_BUILD_ROOT
46
47%files
48%defattr(-,root,root)
49%doc NEWS AUTHORS
50%doc INSTALL COPYING README
51
52%{perlvendorlib}/*
53%{_bindir}/*
54#%{_mandir}/man1/*
55%{_mandir}/man3/*
56
57%changelog
58PBLOG
Note: See TracBrowser for help on using the repository browser.