source: ProjectBuilder/pbconf/devel/project-builder/rpm/project-builder.spec

Last change on this file was 2683, checked in by Bruno Cornec, 21 months ago

Fix some build deps for perl tests and usage and a wrong macro

File size: 1.7 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib %(eval "`PBPERLCMD -V:installvendorlib`"; echo $installvendorlib)
5%define srcname PBPKG
6
7Name: PBPKG
8Version: PBVER
9Release: PBTAGPBSUF
10Summary: PBSUMMARY
11Summary(fr): Project Builder ou pb produit des paquets pour diverses distributions
12License: PBLIC
13Group: PBGRP
14Url: PBURL
15Source: PBREPO/PBSRC
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
17Requires: perl >= 5.6.2,perl-Date-Manip,perl-ProjectBuilder,perl-File-MimeInfo,PBDEP
18# If we want to run make test, we need these modules, but upstream we do tests for this one in another way
19# also pb itself doesn't support using packages at the same time they are built yet
20# see http://trac.project-builder.org/ticket/175
21#BuildRequires: perl-Date-Manip,perl-ProjectBuilder,perl-File-MimeInfo
22PBBUILDARCH: noarch
23PBBUILDDEP
24
25%description
26PBDESC
27
28%description -l fr
29Project Builder ou pb est un programme pour produire des paquets pour
30diverses distributions.
31Il réalise cela en minimisant la duplication des informations requises
32et par un jeu de fichiers de configuration très simples.
33
34%prep
35%setup -q -n %{srcname}-%{version}PBEXTDIR
36
37%build
38PBPERLCMD Makefile.PL INSTALLDIRS=vendor PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
39make
40
41%install
42%{__rm} -rf $RPM_BUILD_ROOT
43make DESTDIR=${RPM_BUILD_ROOT} install
44find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -o -name .packlist -o -name '*.bs' -a -size 0 | xargs rm -f
45find ${RPM_BUILD_ROOT} -type d -depth | xargs rmdir --ignore-fail-on-non-empty
46
47#check
48#make test
49
50%clean
51%{__rm} -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(-,root,root)
55%doc NEWS AUTHORS COPYING README
56%{perlvendorlib}/ProjectBuilder/
57%{_bindir}/pb*
58%{_mandir}/man1/*
59%{_mandir}/man3/*
60
61%changelog
62PBLOG
Note: See TracBrowser for help on using the repository browser.