source: ProjectBuilder/pbconf/devel/project-builder/rpm/project-builder.spec@ 329

Last change on this file since 329 was 329, checked in by Bruno Cornec, 16 years ago
  • All modules are packages now (simplifies use and spec)
File size: 1.4 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
5
6Summary: Project Builder aka pb is a tool to produce packages for multiple distributions
7Summary(fr): Project Builder ou pb est un programme pour produire des paquets pour diverses distributions
8
9Name: PBPKG
10Version: PBVER
11Release: PBTAGPBSUF
12License: GPL
13Group: PBGRP
14Url: http://trac.project-builder.org
15Source: PBSRC
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
17BuildArch: noarch
18Requires: perl >= 5.8.4, perl-DateManip, PBDEP
19
20%description
21Project Builder aka pb is a tool to produce packages for multiple
22distributions.
23It does that by minimizing the duplication of information required
24and a set a very simple configuration files.
25
26%description -l fr
27Project Builder ou pb est un programme pour produire des paquets pour
28diverses distributions.
29Il réalise cela en minimisant la duplication des informations requises
30et par un jeu de fichiers de configuration très simples.
31
32%prep
33%setup -q
34
35%build
36%{__perl} Makefile.PL PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
37make
38
39%install
40%{__rm} -rf $RPM_BUILD_ROOT
41make pure_install
42find ${RPM_BUILD_ROOT} -name perllocal.pod | xargs rm -f
43
44%clean
45%{__rm} -rf $RPM_BUILD_ROOT
46
47%files
48%defattr(-,root,root)
49%doc NEWS AUTHORS
50%doc INSTALL COPYING README contrib/pbsetupqemu
51
52%{perlvendorlib}/*
53%{_bindir}/*
54#%{_mandir}/*/*
55
56%changelog
57PBLOG
Note: See TracBrowser for help on using the repository browser.