source: ProjectBuilder/pbconf/devel/project-builder/rpm/project-builder.spec@ 391

Last change on this file since 391 was 391, checked in by Bruno Cornec, 16 years ago
  • pb: pod content for Distribution.pm and man page delivery
  • dploy: improved pb setup in progress
File size: 1.5 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
5
6Summary: Project Builder aka pb is a tool to produce packages for multiple distributions
7Summary(fr): Project Builder ou pb est un programme pour produire des paquets pour diverses distributions
8
9Name: PBPKG
10Version: PBVER
11Release: PBTAGPBSUF
12License: GPL
13Group: PBGRP
14Url: http://trac.project-builder.org
15Source: PBSRC
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
17BuildArch: noarch
18Requires: perl >= 5.8.4, perl-DateManip, PBDEP
19
20%description
21Project Builder aka pb is a tool to produce packages for multiple
22distributions.
23It does that by minimizing the duplication of information required
24and a set a very simple configuration files.
25
26%description -l fr
27Project Builder ou pb est un programme pour produire des paquets pour
28diverses distributions.
29Il réalise cela en minimisant la duplication des informations requises
30et par un jeu de fichiers de configuration très simples.
31
32%prep
33%setup -q
34
35%build
36%{__perl} Makefile.PL INSTALLDIRS=vendor PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
37make
38
39%install
40%{__rm} -rf $RPM_BUILD_ROOT
41make DESTDIR=${RPM_BUILD_ROOT} install
42find ${RPM_BUILD_ROOT} -name perllocal.pod | xargs rm -f
43
44%check
45make test
46
47%clean
48%{__rm} -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(-,root,root)
52%doc NEWS AUTHORS
53%doc INSTALL COPYING README contrib/pbsetupqemu
54
55%{perlvendorlib}/*
56%{_bindir}/*
57%{_mandir}/man1/*
58%{_mandir}/man3/*
59
60%changelog
61PBLOG
Note: See TracBrowser for help on using the repository browser.