source: ProjectBuilder/pbconf/devel/project-builder/rpm/project-builder.spec@ 624

Last change on this file since 624 was 624, checked in by Bruno Cornec, 15 years ago
  • Fix Project-Builder for perl 5.10 build where .packlist file is generated
File size: 1.4 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
5%define srcname PBPKG
6
7Summary: Project Builder aka pb is a tool to produce packages for multiple distributions
8Summary(fr): Project Builder ou pb est un programme pour produire des paquets pour diverses distributions
9
10Name: PBPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: GPL
14Group: PBGRP
15Url: http://trac.project-builder.org
16Source: PBREPO/PBSRC
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
18BuildArch: noarch
19Requires: perl >= 5.8.4, perl-DateManip, perl-ProjectBuilder, rpm-build, PBDEP
20
21%description
22PBDESC
23
24%description -l fr
25Project Builder ou pb est un programme pour produire des paquets pour
26diverses distributions.
27Il réalise cela en minimisant la duplication des informations requises
28et par un jeu de fichiers de configuration très simples.
29
30%prep
31%setup -q
32
33%build
34%{__perl} Makefile.PL INSTALLDIRS=vendor PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
35make
36
37%install
38%{__rm} -rf $RPM_BUILD_ROOT
39make DESTDIR=${RPM_BUILD_ROOT} install
40find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -o -name .packlist -o -name '*.bs' -a -size 0 | xargs rm -f
41find ${RPM_BUILD_ROOT} -type d -depth | xargs rmdir --ignore-fail-on-non-empty
42
43%check
44make test
45
46%clean
47%{__rm} -rf $RPM_BUILD_ROOT
48
49%files
50%defattr(-,root,root)
51%doc NEWS AUTHORS
52%doc INSTALL COPYING README
53
54%{perlvendorlib}/*
55%{_bindir}/*
56%{_mandir}/man1/*
57%{_mandir}/man3/*
58
59%changelog
60PBLOG
Note: See TracBrowser for help on using the repository browser.