source: ProjectBuilder/projects/dploy/pbconf/devel/dploy-common/rpm/dploy-common.spec@ 421

Last change on this file since 421 was 421, checked in by Bruno Cornec, 16 years ago
  • BuildArch is noarch for dploy
  • Removes vm entries from dploy.pb for 0.9.2 comlpiance
File size: 1.8 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
5
6Summary: dploy.org common tools
7Summary(fr): Outils communs pour dploy.org
8
9Name: PBPKG
10Version: PBVER
11Release: PBTAGPBSUF
12License: GPL
13Group: PBGRP
14Url: PBURL
15Source: PBSRC
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
17BuildArch: noarch
18Requires: openssh, PBDEP
19
20%description
21PBDESC
22
23%description -l fr
24Outils communs pour dploy.org
25
26%prep
27%setup -q
28
29%build
30%{__perl} Makefile.PL INSTALLDIRS=vendor PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
31make
32
33%install
34%{__rm} -rf $RPM_BUILD_ROOT
35export DESTDIR=$RPM_BUILD_ROOT
36export PREFIX=%{_exec_prefix}
37export CONFDIR=%{_sysconfdir}/PBPROJ
38make DESTDIR=$RPM_BUILD_ROOT install
39./install.sh
40find ${RPM_BUILD_ROOT} -name perllocal.pod | xargs rm -f
41
42
43%clean
44%{__rm} -rf $RPM_BUILD_ROOT
45
46%files
47%defattr(-,dploy,dploy)
48%doc ChangeLog
49%config(noreplace) %{_sysconfdir}/PBPROJ
50%doc AUTHORS
51#NEWS
52%doc INSTALL COPYING README
53
54%{perlvendorlib}/*
55#%{_bindir}/*
56#%{_mandir}/man1/*
57%{_mandir}/man3/*
58
59%pre
60# Create dploy Account and group if needed
61grep -qE '^dploy:' /etc/group
62if [ $? -ne 0 ]; then
63 addgroup dploy
64fi
65grep -qE '^dploy:' /etc/passwd
66if [ $? -ne 0 ]; then
67 adduser dploy dploy
68fi
69
70%post
71# Open ssh access for dploy account with generated keys
72mkdir -p ~dploy/.ssh
73chmod 700 ~dploy/.ssh
74keyf=~dploy/.ssh/authorized_keys
75if [ -f $keyf ]; then
76 key=`cut -d' ' -f2 %{_sysconfdir}/PBPROJ/keys/dploy_id_dsa.pub`
77 grep -qE \'$key\' $keyf
78 if [ $? -ne 0 ]; then
79 cat %{_sysconfdir}/PBPROJ/keys/dploy_id_dsa.pub >> $keyf
80 fi
81else
82 cp %{_sysconfdir}/PBPROJ/keys/dploy_id_dsa.pub $keyf
83 chown dploy:dploy $keyf
84 chmod 600 $keyf
85fi
86
87%changelog
88PBLOG
Note: See TracBrowser for help on using the repository browser.