source: ProjectBuilder/projects/fossology/pbconf/trunk/fossology/rpm/fossology.spec@ 605

Last change on this file since 605 was 605, checked in by Bruno Cornec, 16 years ago

fossology depends on libmagic-devel and a dir needs to be created to host the conf file

File size: 3.9 KB
Line 
1#
2# $Id$
3#
4# Used if virtual name != real name (perl, ...)
5#%define srcname PBPKG
6
7Summary: FOSSology is a licenses exploration tool
8Summary(fr): FOSSology est un outil d'exploration de licenses
9
10Name: PBREALPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: PBLIC
14Group: PBGRP
15Url: PBURL
16Source: PBREPO/PBSRC
17#PBPATCHSRC
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
19Requires: postgresql php php-pear php-pgsql libxml2 binutils bzip2 cpio mkisofs poppler-utils rpm tar unzip gzip httpd PBDEP
20BuildRequires: postgresql-devel libxml2 gcc make perl libmagic-devel PBBUILDDEP
21
22%description
23PBDESC
24
25%description -l fr
26FOSSology est un outil d'exploration de licenses
27
28%prep
29%setup -q
30#PBPATCHCMD
31
32%build
33make %{?_smp_mflags} SYSCONFDIR=%{_sysconfdir}
34
35%install
36%{__rm} -rf $RPM_BUILD_ROOT
37make DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_usr} SYSCONFDIR=%{_sysconfdir} LOCALSTATEDIR=%{_var} install
38mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
39cat > $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/fossology.conf << EOF
40Alias /repo/ /usr/share/fossology/www/
41<Directory "/usr/share/fossology/www">
42 AllowOverride None
43 Options FollowSymLinks MultiViews
44 Order allow,deny
45 Allow from all
46 # uncomment to turn on php error reporting
47 #php_flag display_errors on
48 #php_value error_reporting 2039
49</Directory>
50EOF
51
52%clean
53%{__rm} -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(-,root,root)
57%doc ChangeLog
58%doc COPYING COPYING.LGPL HACKING README INSTALL INSTALL.multi LICENSE
59#AUTHORS NEWS
60%dir %{_datadir}/*
61%dir %{_localstatedir}/*
62%dir %{_libexecdir}/*
63%dir %{_sysconfdir}/fossology
64%{_sysconfdir}/httpd/conf.d/*.conf
65%{_sysconfdir}/cron.d/*
66%{_bindir}/*
67%{_mandir}/man1/*
68
69%post
70# Adjust the kernel shmmax (described in detail in section 2.1.3)
71echo 512000000 > /proc/sys/kernel/shmmax
72grep -q kernel.shmmax /etc/sysctl.conf
73if [ $? -eq 0 ]; then
74 perl -pi -e "s/kernel.shmmax\s*=.*/kernel.shmmax=512000000/" /etc/sysctl.conf
75else
76 echo "kernel.shmmax=512000000" >> /etc/sysctl.conf
77fi
78# Adjust postgresql config (described in detail in section 2.1.4)
79# 266 > #hba_file = 'ConfigDir/pg_hba.conf' # host-based authentication file
80# 267 > #ident_file = 'ConfigDir/pg_ident.conf' # IDENT configuration file
81# 268 > #external_pid_file = '(none)' # write an extra pid file
82# 269 > listen_addresses = '*'
83# 270 > max_connections = 50
84# 271 > #shared_buffers = 1000 # min 16 or max_connections*2, 8KB each
85# 272 > shared_buffers = 32768
86# 273 > work_mem = 10240
87# 274 > max_fsm_pages = 100000 # min max_fsm_relations*16, 6 bytes each
88# 275 > fsync = off
89# 276 > full_page_writes = off #recover from partial page writes
90# 277 > commit_delay = 1000
91# 278 > effective_cache_size = 25000
92# 279 > log_min_duration_statement = -1 # -1 is disabled, 0 logs all statements
93# 280 > #log_line_prefix = '' # Special values:
94
95# Adjust PHP config (described in detail in section 2.1.5)
96# /etc/php5/php.ini
97# 291 max_execution_time = 90
98# 292 memory_limit = 128M
99# 293 error_reporting = E_ALL & E_STRICT
100# 294 display_startup_errors = On
101# 295 log_errors = On
102# 296 log_errors_max_len = 0
103# 297 error_log = /var/log/php5.log
104# 298 post_max_size = 700M
105# 299 upload_max_filesize = 701M
106# 300 In the "[soap]" section add
107# 301 extension=pgsql.so
108# 303 You should also edit /etc/php5/cli/php.ini to include the fossology directory
109# 304 in the php command line interface path:
110# 305 include_path = ".:/usr/local/share/fossology/php:/usr/local/share/fossology/www"
111
112# Add apache config for fossology (described in detail in section 2.1.6) - done in install
113/etc/init.d/httpd reload
114
115# Run the postinstall script
116/usr/lib/fossology/fo-postinstall
117
118# Test that things are installed correctly
119/usr/lib/fossology/fossology-scheduler -t
120if [ $? -ne 0 ]; then
121 exit -1
122fi
123
124chkconfig --add fossology
125/etc/init.d/fossology start
126
127%changelog
128PBLOG
129
Note: See TracBrowser for help on using the repository browser.