source: ProjectBuilder/projects/itop/pbconf/devel/itop/rpm/itop.spec@ 1373

Last change on this file since 1373 was 1373, checked in by Bruno Cornec, 12 years ago
  • A first approach to itop configuration
File size: 823 bytes
Line 
1#
2# $Id$
3#
4# Used if virtual name != real name (perl, ...) - replace hash by percent in the below line
5#define srcname PBPKG
6
7Summary: PBSUMMARY
8
9Name: PBREALPKG
10Version: PBVER
11Release: PBTAGPBSUF
12License: PBLIC
13Group: PBGRP
14Url: PBURL
15Source: PBREPO/PBSRC
16#PBPATCHSRC
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
18#Requires: PBDEP
19
20%description
21PBDESC
22
23%prep
24%setup -q
25# Used if virtual name != real name (perl, ...)
26#%setup -q -n %{srcname}-%{version}
27#PBPATCHCMD
28
29%build
30%configure
31make %{?_smp_mflags}
32
33%install
34%{__rm} -rf $RPM_BUILD_ROOT
35make DESTDIR=$RPM_BUILD_ROOT install
36
37%clean
38%{__rm} -rf $RPM_BUILD_ROOT
39
40%files
41%defattr(-,root,root)
42%doc ChangeLog
43%doc INSTALL COPYING README AUTHORS NEWS
44
45%changelog
46PBLOG
47
Note: See TracBrowser for help on using the repository browser.