source: ProjectBuilder/projects/mondorescue/pbconf/branches/2.2.10/mindi-busybox/ebuild/mindi-busybox.ebuild@ 1202

Last change on this file since 1202 was 1202, checked in by Bruno Cornec, 13 years ago
  • USR_SRC for gentoo should contain the src subdir as we do not use the PBSRC macro
File size: 701 bytes
Line 
1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
5inherit eutils flag-o-matic
6
7DESCRIPTION="PBSUMMARY"
8HOMEPAGE="PBURL"
9SRC_URI="PBREPO/src/${P}.tar.gz"
10LICENSE="GPL-2"
11SLOT="0"
12KEYWORDS="~x86 ~ia64 ~amd64 -*"
13DEPEND="virtual/libc"
14RDEPEND=">=app-arch/bzip2-0.9
15 sys-devel/binutils"
16
17src_unpack() {
18 unpack ${A} || die "Failed to unpack ${A}"
19 cd ${P}
20 make oldconfig > /dev/null
21}
22
23src_compile() {
24 # work around broken ass powerpc compilers
25 emake EXTRA_CFLAGS="${CFLAGS}" busybox || die "build failed"
26}
27
28src_install() {
29 # bundle up the symlink files for use later
30 emake CONFIG_PREFIX="${D}/usr/lib/mindi/rootfs" install || die
31}
Note: See TracBrowser for help on using the repository browser.