source: ProjectBuilder/projects/mondorescue/pbconf/branches/2.2.10/mindi/ebuild/mindi.ebuild@ 1202

Last change on this file since 1202 was 1202, checked in by Bruno Cornec, 13 years ago
  • USR_SRC for gentoo should contain the src subdir as we do not use the PBSRC macro
File size: 1.2 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7DESCRIPTION="PBSUMMARY"
8HOMEPAGE="PBURL"
9SRC_URI="PBREPO/src/${P}.tar.gz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="~x86 ~ia64 ~amd64 -*"
14IUSE=""
15
16DEPEND="virtual/libc"
17RDEPEND=">=app-arch/bzip2-0.9
18 sys-libs/ncurses
19 sys-devel/binutils
20 sys-fs/dosfstools
21 sys-block/parted
22 sys-apps/gawk"
23
24src_unpack() {
25 unpack ${A} || die "Failed to unpack ${A}"
26}
27
28src_install() {
29 export HEAD="${D}"
30 export PREFIX="/usr"
31 export CONFDIR="/etc"
32 export MINDI_CACHE="/var/cache/mindi"
33 export MANDIR="${PREFIX}/share/man"
34 export DOCDIR="${PREFIX}/share/doc"
35 export DATADIR="${PREFIX}/share"
36 export DONT_RELINK=1
37 export PKGBUILDMINDI="true"
38 "${WORKDIR}"/"${P}"/install.sh
39}
40
41pkg_postinst() {
42 einfo "${P} was successfully installed."
43 einfo "Please read the associated docs for help."
44 einfo "Or visit the website @ ${HOMEPAGE}"
45 echo
46 ewarn "This package is still in unstable."
47 ewarn "Please report bugs to http://bugs.gentoo.org/"
48 ewarn "However, please do an advanced query to search for bugs"
49 ewarn "before reporting. This will keep down on duplicates."
50 echo
51}
Note: See TracBrowser for help on using the repository browser.