source: ProjectBuilder/projects/mondorescue/pbconf/branches/3.2/MondoRescue/rpm/perl-MondoRescue.spec@ 1825

Last change on this file since 1825 was 1825, checked in by Bruno Cornec, 10 years ago
  • Remove generated Makefile to avoid false check-buildroot issues
File size: 1.4 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
5%define srcname PBPKG
6
7Summary: PBSUMMARY
8Summary(fr): Une bibliothèque de fonction de bas niveau pour le projet MondoRescue
9
10Name: PBREALPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: PBLIC
14Group: PBGRP
15Url: PBURL
16Source: PBREPO/PBSRC
17BuildRoot: %{_tmppath}/%{srcname}-%{version}-%{release}-root-%(id -u -n)
18BuildArch: noarch
19Requires: perl >= 5.6.2,perl-ProjectBuilder,PBDEP
20BuildRequires: PBBUILDDEP
21
22%description
23PBDESC
24
25%description -lfr
26Une bibliothèque de fonction de bas niveau pour le projet MondoRescue
27
28%prep
29%setup -q -n %{srcname}-%{version}
30
31%build
32%{__perl} Makefile.PL PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR CONFDIR=%{_sysconfdir} CACHEDIR=%{_var}/cache TARGET=%{_exec_prefix}
33make %{?_smp_mflags}
34
35%install
36rm -rf $RPM_BUILD_ROOT
37make DESTDIR=$RPM_BUILD_ROOT install
38find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -o -name .packlist -o -name '*.bs' -a -size 0 | xargs rm -f
39find ${RPM_BUILD_ROOT} -type d -depth | xargs rmdir --ignore-fail-on-non-empty
40# To avoid false detection by check-buildroot
41rm -f Makefile
42
43%check
44make test
45
46%clean
47%{__rm} -rf $RPM_BUILD_ROOT
48
49%files
50%defattr(-,root,root,-)
51%config(noreplace) %{_sysconfdir}/PBPROJ
52%doc ChangeLog INSTALL COPYING README NEWS AUTHORS
53
54%{_bindir}/*
55%{_mandir}/man1/*
56%{perlvendorlib}/*
57%{_mandir}/man3/*
58%{_mandir}/man5/*
59#%{_datadir}/PBPROJ
60#%{_var}/cache/PBPROJ
61
62%changelog
63PBLOG
Note: See TracBrowser for help on using the repository browser.