source: ProjectBuilder/projects/mondorescue/pbconf/branches/3.2/mindi-busybox/ebuild/mindi-busybox.ebuild@ 1805

Last change on this file since 1805 was 1805, checked in by Bruno Cornec, 10 years ago
  • mindi-busybox is now built fully under /usr and packge build call the new post install script
File size: 756 bytes
Line 
1# Copyright 1999-2006 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Id$
4
5inherit eutils flag-o-matic
6
7DESCRIPTION="PBSUMMARY"
8HOMEPAGE="PBURL"
9SRC_URI="PBREPO/src/${P}.tar.gz"
10LICENSE="GPL-2"
11SLOT="0"
12KEYWORDS="~x86 ~ia64 ~amd64 -*"
13DEPEND="virtual/libc"
14RDEPEND=">=app-arch/bzip2-0.9
15 sys-devel/binutils"
16export DESTDIR="${D}/usr/lib/mindi/rootfs"
17
18src_unpack() {
19 unpack ${A} || die "Failed to unpack ${A}"
20 cd ${P}
21 make oldconfig > /dev/null
22}
23
24src_compile() {
25 # work around broken ass powerpc compilers
26 emake EXTRA_CFLAGS="${CFLAGS}" busybox || die "build failed"
27}
28
29src_install() {
30 # bundle up the symlink files for use later
31 emake CONFIG_PREFIX="${DESTDIR}" install || die
32 ./mondo-install.sh || die
33}
Note: See TracBrowser for help on using the repository browser.