source: ProjectBuilder/projects/mondorescue/pbconf/branches/3.2/mindi/ebuild/mindi.ebuild@ 1971

Last change on this file since 1971 was 1971, checked in by Bruno Cornec, 9 years ago

Fix gentoo dependencies for mindi (bash moved to app-shells (Marc Elser melser_regs_at_gmxpro.net)

File size: 1.2 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7DESCRIPTION="PBSUMMARY"
8HOMEPAGE="PBURL"
9SRC_URI="PBREPO/src/${P}.tar.gz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="~x86 ~ia64 ~amd64 -*"
14IUSE=""
15
16DEPEND="virtual/libc"
17RDEPEND=">=app-arch/bzip2-0.9
18 sys-libs/ncurses
19 sys-devel/binutils
20 sys-fs/dosfstools
21 sys-apps/mindi-busybox
22 sys-block/parted
23 app-shell/bash
24 sys-apps/gawk"
25
26src_unpack() {
27 unpack ${A} || die "Failed to unpack ${A}"
28}
29
30src_install() {
31 export HEAD="${D}"
32 export PREFIX="/usr"
33 export CONFDIR="/etc"
34 export SBINDIR="/usr/sbin"
35 export CACHEDIR="/var/cache/mindi"
36 export MANDIR="${PREFIX}/share/man"
37 export DOCDIR="${PREFIX}/share/doc"
38 export LIBDIR="${PREFIX}/lib"
39 export DONT_RELINK=1
40 export PKGBUILDMINDI="true"
41 cd "${WORKDIR}"/"${P}"
42 ./install.sh
43}
44
45pkg_postinst() {
46 einfo "${P} was successfully installed."
47 einfo "Please read the associated docs for help."
48 einfo "Or visit the website @ ${HOMEPAGE}"
49 echo
50 ewarn "This package is still in unstable."
51 ewarn "Please report bugs to http://bugs.gentoo.org/"
52 ewarn "However, please do an advanced query to search for bugs"
53 ewarn "before reporting. This will keep down on duplicates."
54 echo
55}
Note: See TracBrowser for help on using the repository browser.