source: ProjectBuilder/projects/mondorescue/pbconf/branches/3.2/mondo/ebuild/mondo-rescue.ebuild@ 1794

Last change on this file since 1794 was 1303, checked in by Bruno Cornec, 13 years ago
  • Fix ebuild generation for mindi and mondo as reported in #99 by Francesco
File size: 1.6 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7inherit libtool
8
9DESCRIPTION="PBSUMMARY"
10HOMEPAGE="PBURL"
11SRC_URI="PBREPO/src/${P}.tar.gz"
12
13LICENSE="GPL-2"
14SLOT="0"
15KEYWORDS="~x86 ~ia64 ~amd64 -*"
16IUSE=""
17
18DEPEND="virtual/libc
19 >=sys-libs/slang-1.4.1
20 >=dev-libs/newt-0.50"
21RDEPEND="app-arch/afio
22 sys-block/buffer
23 sys-devel/binutils
24 >=app-arch/bzip2-0.9
25 virtual/cdrtools
26 >=sys-apps/mindi-2.0.7
27 >=dev-libs/newt-0.50
28 >=sys-libs/slang-1.4.1
29 sys-block/parted
30 >=sys-boot/syslinux-1.52"
31
32S="${WORKDIR}/${PN/-rescue/}-${PV}"
33
34src_unpack() {
35 unpack ${A}
36 cd "${S}"
37 chmod 750 configure
38}
39
40src_compile() {
41 elibtoolize
42 econf || die "Configuration failed"
43 emake VERSION=PBVER || die "Make failed"
44}
45
46src_install() {
47 make install DESTDIR="${D}" || die "make install failed"
48 mkdir -p "${D}/var/cache/mondo"
49 exeinto /usr/share/mondo
50 doexe /usr/share/mondo/autorun
51}
52
53pkg_postinst() {
54 einfo "${P} was successfully installed."
55 einfo "Please read the associated docs for help."
56 einfo "Or visit the website @ ${HOMEPAGE}"
57 echo
58 ewarn "This package is a new version after a long gap."
59 ewarn "Please report bugs to http://bugs.gentoo.org/"
60 ewarn "However, please do an advanced query to search for bugs"
61 ewarn "before reporting. This will keep down on duplicates."
62 echo
63 einfo "Prior to running mondo, ensure /boot is mounted."
64 ewarn "Grub users need to have a symlink like this:"
65 ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
66 einfo "Unless you want to have mondo backup your distfiles,"
67 einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
68 echo
69}
Note: See TracBrowser for help on using the repository browser.