source: ProjectBuilder/projects/mondorescue/pbconf/branches/3.3/mondo/ebuild/mondo-rescue.ebuild@ 2346

Last change on this file since 2346 was 2346, checked in by Bruno Cornec, 6 years ago

Fix dependencies and arch:

  • mindi requires either syslinux or elilo
  • mondo deosn't require syslinux by itself
  • fix allowaed archs instead of excluding some
File size: 1.6 KB
Line 
1# Copyright 1999-2004 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4
5# $Id$
6
7inherit libtool
8
9DESCRIPTION="PBSUMMARY"
10HOMEPAGE="PBURL"
11SRC_URI="PBREPO/src/${P}.tar.gz"
12
13LICENSE="GPL-2"
14SLOT="0"
15KEYWORDS="~x86 ~ia64 ~amd64 -*"
16IUSE=""
17
18DEPEND="virtual/libc
19 >=sys-libs/slang-1.4.1
20 >=dev-libs/newt-0.50"
21RDEPEND="app-arch/afio
22 sys-block/buffer
23 sys-devel/binutils
24 >=app-arch/bzip2-0.9
25 virtual/cdrtools
26 >=sys-apps/mindi-3.0.*
27 >=dev-libs/newt-0.50
28 >=sys-libs/slang-1.4.1
29 sys-block/parted"
30
31S="${WORKDIR}/${PN/-rescue/}-${PV}"
32
33src_unpack() {
34 unpack ${A}
35 cd "${S}"
36 chmod 750 configure
37}
38
39src_compile() {
40 elibtoolize
41 econf || die "Configuration failed"
42 emake VERSION=PBVER || die "Make failed"
43}
44
45src_install() {
46 make install DESTDIR="${D}" || die "make install failed"
47 mkdir -p "${D}/var/cache/mondo"
48 exeinto /usr/share/mondo
49 doexe /usr/share/mondo/autorun
50}
51
52pkg_postinst() {
53 einfo "${P} was successfully installed."
54 einfo "Please read the associated docs for help."
55 einfo "Or visit the website @ ${HOMEPAGE}"
56 echo
57 ewarn "This package is a new version after a long gap."
58 ewarn "Please report bugs to http://bugs.gentoo.org/"
59 ewarn "However, please do an advanced query to search for bugs"
60 ewarn "before reporting. This will keep down on duplicates."
61 echo
62 einfo "Prior to running mondo, ensure /boot is mounted."
63 ewarn "Grub users need to have a symlink like this:"
64 ewarn "ln -s /boot/grub/menu.lst /etc/grub.conf"
65 einfo "Unless you want to have mondo backup your distfiles,"
66 einfo "append \"-E ${DISTDIR}\" to your mondoarchive command."
67 echo
68}
Note: See TracBrowser for help on using the repository browser.