source: ProjectBuilder/projects/mondorescue/pbconf/devel/MondoRescue/rpm/perl-MondoRescue.spec@ 960

Last change on this file since 960 was 960, checked in by Bruno Cornec, 14 years ago

r3575@localhost: bruno | 2010-01-08 01:11:52 +0100
Working devel packages for mondorescue

File size: 1.5 KB
Line 
1#
2# $Id$
3#
4%define perlvendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
5%define srcname PBPKG
6
7Summary: PBSUMMARY
8Summary(fr): Une bibliotheque de fonction de bas niveau pour le projet MondoRescue
9
10Name: PBREALPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: PBLIC
14Group: PBGRP
15Url: PBURL
16Source: PBREPO/PBSRC
17BuildRoot: %{_tmppath}/%{srcname}-%{version}-%{release}-root-%(id -u -n)
18BuildArch: noarch
19Requires: perl >= 5.8.4, PBDEP
20
21%description
22PBDESC
23
24%description -l fr
25Une bibliotheque de fonction de bas niveau pour le projet MondoRescue
26
27%prep
28%setup -q -n %{srcname}-%{version}
29
30%build
31%{__perl} Makefile.PL INSTALLDIRS=vendor PBKEYWORD=${RPM_BUILD_ROOT}/PBFINALDIR
32make %{?_smp_mflags}
33
34%install
35rm -rf $RPM_BUILD_ROOT
36make DESTDIR=$RPM_BUILD_ROOT install
37find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -o -name .packlist -o -name '*.bs' -a -size 0 | xargs rm -f
38find ${RPM_BUILD_ROOT} -type d -depth | xargs rmdir --ignore-fail-on-non-empty
39
40# Finalyse instalation
41export HEAD=${RPM_BUILD_ROOT}
42export PREFIX=%{_exec_prefix}
43export CONFDIR=%{_sysconfdir}
44export CACHEDIR=%{_var}/cache/PBPROJ
45export PERLDIR=%{perlvendorlib}
46./post-install.sh
47
48%check
49make test
50
51%clean
52%{__rm} -rf $RPM_BUILD_ROOT
53
54%files
55%defattr(-,root,root,-)
56%config(noreplace) %{_sysconfdir}/PBPROJ
57%doc ChangeLog INSTALL COPYING README NEWS AUTHORS
58
59%{_bindir}/*
60%{_mandir}/man1/*
61%{perlvendorlib}/*
62%{_mandir}/man3/*
63%{_datadir}/PBPROJ
64%{_var}/cache/PBPROJ
65
66
67%changelog
68PBLOG
Note: See TracBrowser for help on using the repository browser.