source: ProjectBuilder/projects/python-tortilla/pbconf/devel/python-tortilla/rpm/python-tortilla.spec@ 2405

Last change on this file since 2405 was 2405, checked in by Bruno Cornec, 5 years ago

Adds python-tortilla project

File size: 1.3 KB
Line 
1#
2# $Id$
3#
4# Used if virtual name != real name (perl, ...) - replace PBPKG by PBREALPKG in the line below
5%define srcname PBPKG
6%define py3 PBPY3
7
8Summary: PBSUMMARY
9
10Name: PBREALPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: PBLIC
14Group: PBGRP
15Url: PBURL
16Source: PBREPO/PBSRC
17BuildArch: noarch
18#PBPATCHSRC
19Requires: PBDEP
20BuildRequires: PBBDEP
21
22%description
23PBDESC
24python2 version
25
26%if %py3
27%package -n python3-tortilla
28Summary: %{summary} / Python 3 library
29Requires: python3-requests
30Requires: python3-six
31Requires: python3-formats
32Requires: python3-colorclass
33#BuildRequires: python3-setuptools
34
35%description -n python3-tortilla
36PBDESC
37python3 version
38%endif
39
40%prep
41%setup -q -n %{srcname}-%{version}PBEXTDIR
42%if %py3
43cd ..
44cp -fr %{srcname}-%{version}PBEXTDIR python3
45cd -
46%endif
47#PBPATCHCMD
48
49%build
50%{__python} setup.py build
51%if %py3
52cd ../python3
53%{__python3} setup.py build
54cd -
55%endif
56
57%install
58%{__rm} -rf %{buildroot}
59%{__python} setup.py install -O1 --skip-build --root %{buildroot}
60%if %py3
61cd ../python3
62%{__python3} setup.py install -O1 --skip-build --root %{buildroot}
63cd -
64%endif
65
66%files
67%doc README.rst
68%{python_sitelib}/*
69
70%if %py3
71%files -n python3-tortilla
72%doc README.rst
73%{python3_sitelib}/*
74%endif
75
76%changelog
77PBLOG
78
79
Note: See TracBrowser for help on using the repository browser.