source: ProjectBuilder/projects/schroot/pbconf/devel/schroot/rpm/schroot.spec@ 666

Last change on this file since 666 was 666, checked in by Bruno Cornec, 15 years ago

Working schroot rpm for Mandriva

File size: 1.4 KB
Line 
1#
2# $Id$
3#
4# Used if virtual name != real name (perl, ...)
5#%define srcname PBPKG
6
7Summary: Execute commands in a chroot environment
8Summary(fr): Exécute des commandes dans un environnement chrooté
9
10Name: PBREALPKG
11Version: PBVER
12Release: PBTAGPBSUF
13License: PBLIC
14Group: PBGRP
15Url: PBURL
16Source: PBREPO/PBSRC
17PBPATCHSRC
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
19Requires: PBDEP e2fsprogs pam
20BuildRequires: PBBUILDDEP e2fsprogs-devel e2fsprogs pam-devel gcc-c++
21
22%description
23PBDESC
24
25%description -l fr
26Exécute des commandes dans un environnement chrooté
27
28%prep
29%setup -q
30# Used if virtual name != real name (perl, ...)
31#%setup -q -n %{srcname}-%{version}
32PBPATCHCMD
33
34%build
35%configure UUID_CFLAGS=-I/usr/include UUID_LIBS=-luuid --enable-static --disable-shared
36make %{?_smp_mflags}
37
38%install
39%{__rm} -rf $RPM_BUILD_ROOT
40make DESTDIR=$RPM_BUILD_ROOT install
41
42%clean
43%{__rm} -rf $RPM_BUILD_ROOT
44
45%files
46%defattr(-,root,root,-)
47%doc ChangeLog
48%doc INSTALL THANKS README TODO NEWS
49%config /etc/pam.d/schroot
50%config /etc/schroot/*
51%attr(4755, root, root) %{_bindir}/schroot
52%{_mandir}/*/*
53%dir %{_includedir}/sbuild
54%{_includedir}/sbuild/*
55%{_libdir}/pkgconfig/sbuild.pc
56%{_libdir}/libsbuild.a
57%{_libdir}/libsbuild.la
58%dir %{_libexecdir}/schroot
59%{_libexecdir}/schroot/*
60%{_datadir}/locale/*/*/schroot.mo
61
62%changelog
63PBLOG
64
Note: See TracBrowser for help on using the repository browser.