Changeset 1147


Ignore:
Timestamp:
Jan 11, 2011, 1:13:43 PM (9 years ago)
Author:
bruno
Message:
  • A inimal version of Test::More is required to perform test (especially on older version). Now fixed
Location:
devel/pb-modules/t
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • devel/pb-modules/t/Base.t

    r1109 r1147  
    88eval
    99{
    10   require Test::More;
    11   Test::More->import();
     10    require Test::More;
     11    Test::More->import();
     12    my ($tmv,$tmsv) = split(/\./,$Test::More::VERSION);
     13    if ($tmsv lt 87) {
     14        die "Test::More is not available in an appropriate version ($tmsv)";
     15    }
    1216};
    1317
    14 # Test::More not found so no test will be performed here
     18# Test::More appropriate version not found so no test will be performed here
    1519if ($@) {
    1620    require Test;
    1721    plan(tests => 1);
    18     print "# Faking tests as test::More is not available\n";
     22    print "# Faking tests as Test::More is not available in an appropriate version\n";
    1923    ok(1,1);
    20     exit (0);
     24    exit(0);
    2125}
    2226
  • devel/pb-modules/t/Log.t

    r1109 r1147  
    88eval
    99{
    10   require Test::More;
    11   Test::More->import();
     10    require Test::More;
     11    Test::More->import();
     12    my ($tmv,$tmsv) = split(/\./,$Test::More::VERSION);
     13    if ($tmsv lt 87) {
     14        die "Test::More is not available in an appropriate version ($tmsv)";
     15    }
    1216};
    1317
     
    1620    require Test;
    1721    plan(tests => 1);
    18     print "# Faking tests as test::More is not available\n";
     22    print "# Faking tests as test::More is not available in an appropriate version\n";
    1923    ok(1,1);
    2024    exit (0);
Note: See TracChangeset for help on using the changeset viewer.