Changeset 1521


Ignore:
Timestamp:
May 12, 2012, 1:46:09 AM (7 years ago)
Author:
bruno
Message:
  • pb.conf: add auto-agree-with-licenses for opensuse, other failures on install can occur. partially fix dependencies for opensuse-11.2, stopped because the version isn't supported. remove cracklib-dict-small, not actually a dependency. (Eric Anderson)
  • Distribution.pm: Fix bug, if we install with yum, put the repo in the yum location. If we install with zypper, put it in the zypper location. Otherwise complain that we don't know what to do with the file. (Eric Anderson/Bruno? Cornec)
Location:
devel/pb-modules
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • devel/pb-modules/etc/pb.conf

    r1519 r1521  
    238238osins opensuse-10.2 = yes | sudo /usr/bin/zypper install
    239239osins opensuse-11.1 = sudo /usr/bin/zypper -n install
    240 osins opensuse = sudo /usr/bin/zypper --gpg-auto-import-keys -n install
     240osins opensuse = sudo /usr/bin/zypper --gpg-auto-import-keys -n install --auto-agree-with-licenses
    241241osins sol = sudo pkgadd -d
    242242osins lsb = /bin/true
     
    333333rbsmindep opensuse-11.1 = ConsoleKit,cracklib-dict-small,PolicyKit,aaa_base,audit-libs,bash,boost-license,bzip2,coreutils,coreutils-lang,cpio,cpio-lang,cracklib,cyrus-sasl,dbus-1,dbus-1-glib,device-mapper,diffutils,dirmngr,e2fsprogs,ethtool,expat,filesystem,fillup,findutils,gawk,gdbm,glib2,glib2-branding-upstream,glib2-lang,glibc,gpg2,gpg2-lang,grep,gzip,hal,info,insserv,keyutils-libs,krb5,libacl,libattr,libboost_signals1_36_0,libbz2-1,libcom_err2,libcurl4,libdb-4_5,libexpat1,libgcc43,libgcrypt11,libglib-2_0-0,libgobject-2_0-0,libgthread-2_0-0,libgpg-error0,libidn,libksba,libldap-2_4-2,libncurses5,libnscd,libopenssl0_9_8,libreadline5,libreiserfs,libselinux1,libsepol1,libsmbios2,libstdc++43,libusb-0_1-4,libuuid1,libvolume_id1,libxcrypt,libxml2,libxml2-python,libzio,libzypp,login,mingetty,module-init-tools,ncurses-utils,neon,net-tools,openSUSE-release,openSUSE-release-ftp,openslp,pam,pam-config,pam-modules,parted,pciutils,pcre,perl-base,permissions,pinentry,pm-utils,pmtools,popt,procps,psmisc,pth,pwdutils,python,python-urlgrabber,rpm,rpm-python,satsolver-tools,sed,setserial,sysvinit,termcap,terminfo-base,udev,util-linux,uuid-runtime,zlib,zypper
    334334#
    335 rbsmindep opensuse-11.2 = ConsoleKit,cracklib-dict-small,PolicyKit,aaa_base,audit-libs,bash,boost-license,bzip2,coreutils,coreutils-lang,cpio,cpio-lang,cracklib,cyrus-sasl,dbus-1,dbus-1-glib,device-mapper,diffutils,dirmngr,e2fsprogs,ethtool,expat,filesystem,fillup,findutils,gawk,gdbm,glib2,glib2-branding-upstream,glib2-lang,glibc,gpg2,gpg2-lang,grep,gzip,hal,info,insserv,keyutils-libs,krb5,libacl,libattr,libboost_signals1_36_0,libbz2-1,libcom_err2,libcurl4,libdb-4_5,libexpat1,libgcc43,libgcrypt11,libglib-2_0-0,libgobject-2_0-0,libgthread-2_0-0,libgpg-error0,libidn,libksba,libldap-2_4-2,libncurses5,libnscd,libopenssl0_9_8,libreadline5,libreiserfs,libselinux1,libsepol1,libsmbios2,libstdc++43,libusb-0_1-4,libuuid1,libvolume_id1,libxcrypt,libxml2,libxml2-python,libzio,libzypp,login,mingetty,module-init-tools,ncurses-utils,neon,net-tools,openSUSE-release,openSUSE-release-ftp,openslp,pam,pam-config,pam-modules,parted,pciutils,pcre,perl-base,permissions,pinentry,pm-utils,pmtools,popt,procps,psmisc,pth,pwdutils,python,python-urlgrabber,rpm,rpm-python,satsolver-tools,sed,setserial,sysvinit,termcap,terminfo-base,udev,util-linux,uuid-runtime,zlib,zypper
     335#rbsmindep opensuse-11.2 = ConsoleKit,cracklib-dict-small,PolicyKit,aaa_base,audit-libs,bash,boost-license,bzip2,coreutils,coreutils-lang,cpio,cpio-lang,cracklib,cyrus-sasl,dbus-1,dbus-1-glib,device-mapper,diffutils,dirmngr,e2fsprogs,ethtool,expat,filesystem,fillup,findutils,gawk,gdbm,glib2,glib2-branding-upstream,glib2-lang,glibc,gpg2,gpg2-lang,grep,gzip,hal,info,insserv,keyutils-libs,krb5,libacl,libattr,libboost_signals1_36_0,libbz2-1,libcom_err2,libcurl4,libdb-4_5,libexpat1,libgcc43,libgcrypt11,libglib-2_0-0,libgobject-2_0-0,libgthread-2_0-0,libgpg-error0,libidn,libksba,libldap-2_4-2,libncurses5,libnscd,libopenssl0_9_8,libreadline5,libreiserfs,libselinux1,libsepol1,libsmbios2,libstdc++43,libusb-0_1-4,libuuid1,libvolume_id1,libxcrypt,libxml2,libxml2-python,libzio,libzypp,login,mingetty,module-init-tools,ncurses-utils,neon,net-tools,openSUSE-release,openSUSE-release-ftp,openslp,pam,pam-config,pam-modules,parted,pciutils,pcre,perl-base,permissions,pinentry,pm-utils,pmtools,popt,procps,psmisc,pth,pwdutils,python,python-urlgrabber,rpm,rpm-python,satsolver-tools,sed,setserial,sysvinit,termcap,terminfo-base,udev,util-linux,uuid-runtime,zlib,zypper
     336# Below is partially fixed, but untested.  It was not working as of 2012-03-19, but is unsupported, so stopped fixing.
     337rbsmindep opensuse-11.2 = ConsoleKit,cracklib-dict-small,PolicyKit,aaa_base,audit-libs,bash,bzip2,coreutils,cpio,cracklib,cyrus-sasl,dbus-1,dbus-1-glib,device-mapper,diffutils,dirmngr,e2fsprogs,ethtool,expat,filesystem,fillup,findutils,gawk,gdbm,glib2,glib2-branding-upstream,glibc,gpg2,grep,gzip,hal,info,insserv,keyutils-libs,krb5,libacl,libattr,libaugeas0,libbz2-1,libcom_err2,libcurl4,libdb-4_5,libexpat1,libgcrypt11,libglib-2_0-0,libgobject-2_0-0,libgthread-2_0-0,libgpg-error0,libidn,libksba,libldap-2_4-2,libncurses5,libnscd,libopenssl0_9_8,libreadline5,libreadline6,libreiserfs,libselinux1,libsepol1,libsmbios2,libstdc++44,libusb-0_1-4,libuuid1,libvolume_id1,libxcrypt,libxml2,libxml2-python,libzio,libzypp,login,mingetty,module-init-tools,ncurses-utils,neon,net-tools,openSUSE-release,openSUSE-release-ftp,openslp,pam,pam-config,pam-modules,parted,pciutils,pcre,perl-base,permissions,pinentry,pm-utils,procps,psmisc,pwdutils,python,rpm,rpm-python,satsolver-tools,sed,setserial,sysvinit,termcap,terminfo-base,udev,util-linux,zlib,zypper
    336338#
    337339rbsmindep opensuse-11.3 = ConsoleKit,cracklib-dict-small,PolicyKit,aaa_base,audit-libs,bash,boost-license,bzip2,coreutils,coreutils-lang,cpio,cpio-lang,cracklib,cyrus-sasl,dbus-1,dbus-1-glib,device-mapper,diffutils,dirmngr,e2fsprogs,ethtool,expat,filesystem,fillup,findutils,gawk,gdbm,glib2,glib2-branding-upstream,glib2-lang,glibc,gpg2,gpg2-lang,grep,gzip,hal,info,insserv,keyutils-libs,krb5,libacl,libattr,libboost_signals1_36_0,libbz2-1,libcom_err2,libcurl4,libdb-4_5,libexpat1,libgcc43,libgcrypt11,libglib-2_0-0,libgobject-2_0-0,libgthread-2_0-0,libgpg-error0,libidn,libksba,libldap-2_4-2,libncurses5,libnscd,libopenssl0_9_8,libreadline5,libreiserfs,libselinux1,libsepol1,libsmbios2,libstdc++43,libusb-0_1-4,libuuid1,libvolume_id1,libxcrypt,libxml2,libxml2-python,libzio,libzypp,login,mingetty,module-init-tools,ncurses-utils,neon,net-tools,openSUSE-release,openSUSE-release-ftp,openslp,pam,pam-config,pam-modules,parted,pciutils,pcre,perl-base,permissions,pinentry,pm-utils,pmtools,popt,procps,psmisc,pth,pwdutils,python,python-urlgrabber,rpm,rpm-python,satsolver-tools,sed,setserial,sysvinit,termcap,terminfo-base,udev,util-linux,uuid-runtime,zlib,zypper
    338340#
    339 rbsmindep opensuse-11.4 = ConsoleKit,cracklib-dict-small,PolicyKit,aaa_base,bash,bzip2,coreutils,cpio,cracklib,cyrus-sasl,dbus-1,dbus-1-glib,device-mapper,diffutils,dirmngr,e2fsprogs,ethtool,expat,filesystem,fillup,findutils,gawk,gdbm,glib2-branding-upstream,glibc,gpg2,grep,gzip,hal,info,insserv,keyutils-libs,krb5,libacl,libassuan0,libattr,libaugeas0,libbz2-1,libcap2,libcom_err2,libcurl4,libdb-4_5,libelf1,libexpat1,libgcc45,libgcrypt11,libglib-2_0-0,libgobject-2_0-0,libgthread-2_0-0,libgpg-error0,libidn,libksba,libldap-2_4-2,liblua5_1,liblzma5,libmodman1,libncurses5,libnscd,libopenssl1_0_0,libpopt0,libproxy1,libreadline6,libreiserfs,libselinux1,libsepol1,libsmbios2,libssh2-1,libstdc++45,libudev0,libusb-0_1-4,libuuid1,libxcrypt,libxml2,libxml2-python,libzio,libzypp,login,mingetty,module-init-tools,ncurses-utils,net-tools,openSUSE-release,openSUSE-release-ftp,openslp,pam,pam-config,pam-modules,parted,pciutils,perl-base,permissions,pinentry,pm-utils,procps,psmisc,pwdutils,python,rpm,rpm-python,satsolver-tools,sed,setserial,sysvinit,termcap,terminfo-base,udev,util-linux,zlib,zypper
     341rbsmindep opensuse-11.4 = ConsoleKit,PolicyKit,aaa_base,bash,bzip2,coreutils,cpio,cracklib,cyrus-sasl,dbus-1,dbus-1-glib,device-mapper,diffutils,dirmngr,e2fsprogs,ethtool,expat,filesystem,fillup,findutils,gawk,gdbm,glib2-branding-upstream,glibc,gpg2,grep,gzip,hal,info,insserv,keyutils-libs,krb5,libacl,libassuan0,libattr,libaugeas0,libbz2-1,libcap2,libcom_err2,libcurl4,libdb-4_5,libelf1,libexpat1,libgcc45,libgcrypt11,libglib-2_0-0,libgobject-2_0-0,libgthread-2_0-0,libgpg-error0,libidn,libksba,libldap-2_4-2,liblua5_1,liblzma5,libmodman1,libncurses5,libnscd,libopenssl1_0_0,libpopt0,libproxy1,libreadline6,libreiserfs,libselinux1,libsepol1,libsmbios2,libssh2-1,libstdc++45,libudev0,libusb-0_1-4,libuuid1,libxcrypt,libxml2,libxml2-python,libzio,libzypp,login,mingetty,module-init-tools,ncurses-utils,net-tools,openSUSE-release,openSUSE-release-ftp,openslp,pam,pam-config,pam-modules,parted,pciutils,perl-base,permissions,pinentry,pm-utils,procps,psmisc,pwdutils,python,rpm,rpm-python,satsolver-tools,sed,setserial,sysvinit,termcap,terminfo-base,udev,util-linux,zlib,zypper
    340342#
    341343rbsmindep opensuse-12.1 = ConsoleKit,cracklib-dict-small,PolicyKit,aaa_base,bash,bzip2,coreutils,cpio,cracklib,cyrus-sasl,dbus-1,dbus-1-glib,device-mapper,diffutils,dirmngr,e2fsprogs,ethtool,expat,filesystem,fillup,findutils,gawk,gdbm,glibc,gpg2,grep,gzip,info,insserv,krb5,libacl1,libassuan0,libattr1,libaugeas0,libbz2-1,libcap2,libcares2,libcom_err2,libcurl4,libdb-4_5,libelf1,libexpat1,libgcc46,libgcrypt11,libglib-2_0-0,libgobject-2_0-0,libgthread-2_0-0,libgpg-error0,libidn,libkeyutils1,libksba,libldap-2_4-2,liblua5_1,liblzma5,libmodman1,libncurses5,libnscd,libopenssl1_0_0,libpopt0,libproxy1,libreadline6,libreiserfs,libselinux1,libsepol1,libsmbios2,libsolv-tools,libssh2-1,libstdc++46,libudev0,libusb-0_1-4,libuuid1,libxcrypt,libxml2,libxml2-python,libzio,libzypp,login,mingetty,module-init-tools,ncurses-utils,net-tools,openSUSE-release,openSUSE-release-ftp,openslp,pam,pam-config,pam-modules,parted,pciutils,perl-base,permissions,pinentry,pm-utils,procps,psmisc,pwdutils,python,rpm,rpm-python,sed,setserial,sysvinit,termcap,terminfo-base,udev,util-linux,zlib,zypper
     
    380382# kernel.org is not up to date anymore for opensuse
    381383#rbsmirrorsrv opensuse = http://mirrors.kernel.org/opensuse/distribution/$pbos->{'version'}/repo/oss/suse/$pbos->{'arch'}/
     384#rbsmirrorsrv opensuse = http://mirror.rackspace.com/openSUSE/distribution/$pbos->{'version'}/repo/oss/suse/$pbos->{'arch'}/
    382385rbsmirrorsrv opensuse = http://download.opensuse.org/distribution/$pbos->{'version'}/repo/oss/suse/$pbos->{'arch'}/
    383386# pbos->{'arch'} == i586 for i386 repo
  • devel/pb-modules/lib/ProjectBuilder/Distribution.pm

    r1520 r1521  
    555555            }
    556556        } elsif ($bn =~ /\.repo$/) {
    557             # Yum repo
    558             my $dest = "/etc/yum.repos.d/$bn";
     557            my $dirdest = "";
     558            my $reponame = "";
     559            # TODO: could go in pb.conf in fact
     560            if ($pbos->{install} =~ /\byum\b/) {
     561                $reponame="yum";
     562                $dirdest = "/etc/yum.repos.d";
     563            } elsif ($pbos->{install} =~ /\bzypper\b/) {
     564                $reponame="zypper";
     565                $dirdest = "/etc/zypp/repos.d";
     566            } else {
     567                die "Unknown location for repository file for '$pbos->{install}' command";
     568            }
     569            my $dest = "$dirdest/$bn";
    559570            return if (pb_distro_compare_repo($ENV{'PBTMP'}/$bn,$dest));
    560             pb_system("sudo mv $ENV{'PBTMP'}/$bn /etc/yum.repos.d","Adding yum repository") if (not -f "/etc/yum.repos.d/$bn");
     571            die "Missing directory $dirdest ($reponame)" unless (-d $dirdest);
     572            pb_system("sudo mv $ENV{'PBTMP'}/$bn $dirdest/$bn","Adding $reponame repository") if (not -f "$dirdest/$bn");
    561573        } elsif ($bn =~ /\.addmedia/) {
    562574            # URPMI repo
Note: See TracChangeset for help on using the changeset viewer.