Changeset 2189


Ignore:
Timestamp:
Mar 3, 2017, 4:07:35 AM (3 years ago)
Author:
bruno
Message:

Fix a bug on the analysis of build dependencies for deb packages when using
multiple versions constraints

File:
1 edited

Legend:

Unmodified
Added
Removed
  • devel/pb-modules/lib/ProjectBuilder/Distribution.pm

    r2188 r2189  
    331331
    332332This function install the dependencies required to build the package on a distro.
    333 If $forcerepo is defined then do not assumer package are alredy installed, but reinstall them
     333If $forcerepo is defined then do not assume packages are alredy installed, but reinstall them
    334334(useful if you add a repo which contains more up to date packages that you need)
    335335Dependencies can be passed as the 4th parameter in which case they are not computed
     
    426426    pb_log(4,"found deps 1: $_\n");
    427427    # Remove conditions in the middle and at the end for deb
    428     s/\(\s*[><=]+.*\)[^,]*,/,/g;
     428    s/\([><=]+[^,]*,/,/g;
    429429    pb_log(4,"found deps 2: $_\n");
    430     s/\(\s*[><=]+.*$//g;
     430    s/\([><=]+[^,]*$//g;
    431431    pb_log(4,"found deps 3: $_\n");
    432432    # Same for rpm
Note: See TracChangeset for help on using the changeset viewer.