Changeset 2346


Ignore:
Timestamp:
Oct 16, 2018, 12:36:00 PM (5 weeks ago)
Author:
bruno
Message:

Fix dependencies and arch:

  • mindi requires either syslinux or elilo
  • mondo deosn't require syslinux by itself
  • fix allowaed archs instead of excluding some
Location:
projects/mondorescue/pbconf/branches/3.3
Files:
4 edited

Legend:

Unmodified
Added
Removed
  • projects/mondorescue/pbconf/branches/3.3/mindi/deb/control

    r2174 r2346  
    88Package: PBPKG
    99Architecture: amd64 i386 ia64
    10 Depends: bash, binutils, bzip2, dosfstools, module-init-tools|kmod, syslinux [amd64 i386], gawk, parted, file, mtools, libmondorescue-perl, libmodule-scandeps-perl, libio-interface-perl,util-linux, mindi-busybox (>= 1.21.1), mkisofs|genisoimage|xorriso, PBDEP
     10Depends: bash, binutils, bzip2, dosfstools, module-init-tools|kmod, syslinux [amd64 i386] (>= 1.52), elilo [ia64], gawk, parted, file, mtools, libmondorescue-perl, libmodule-scandeps-perl, libio-interface-perl,util-linux, mindi-busybox (>= 1.21.1), mkisofs|genisoimage|xorriso, PBDEP
    1111Recommends: cpio, mdadm, ntfsprogs|ntfs-3g, nano
    1212Suggests: eject, less
  • projects/mondorescue/pbconf/branches/3.3/mindi/rpm/mindi.spec

    r2342 r2346  
    3030Requires:   perl-MondoRescue
    3131Requires:   mtools
    32 Requires:   syslinux
     32%ifarch ia64
     33Requires:   elilo
     34%else
     35Requires:   syslinux >= 1.52
     36%endif
    3337Requires:   perl-Module-ScanDeps,PBDEP
    34 ExcludeArch:    ppc
     38ExclusiveArch:  x86_64 i586 i386 i686 ia64
    3539PBOBS
    3640# Not on all systems
  • projects/mondorescue/pbconf/branches/3.3/mondo/ebuild/mondo-rescue.ebuild

    r1974 r2346  
    2727    >=dev-libs/newt-0.50
    2828    >=sys-libs/slang-1.4.1
    29     sys-block/parted
    30     >=sys-boot/syslinux-1.52"
     29    sys-block/parted"
    3130
    3231S="${WORKDIR}/${PN/-rescue/}-${PV}"
  • projects/mondorescue/pbconf/branches/3.3/mondo/rpm/mondo.spec

    r2282 r2346  
    2121BuildRequires:  automake
    2222BuildRequires:  libtool
    23 ExcludeArch:    ppc
     23ExclusiveArch:  x86_64 i586 i386 i686 ia64
    2424PBOBS
    2525Requires:   mindi >= 3.0.2, PBDEP
     
    3131Requires:   parted
    3232Requires:   net-tools
    33 %ifarch ia64
    34 Requires:   elilo
    35 %else
    36 Requires:   syslinux >= 1.52
    37 %endif
    3833
    3934%description
Note: See TracChangeset for help on using the changeset viewer.