source: ProjectBuilder/projects/dploy/pbconf/devel/dploy-pxe/rpm/dploy-pxe.spec@ 470

Last change on this file since 470 was 470, checked in by Bruno Cornec, 16 years ago
  • dploy-pxe requires syslinux (at least on rhel 5)
  • dploy-pxe adds permission to mount/umount iso images via sudoers
  • dploy-pxe now creates all required dirs under /tftpboot
  • dploy-dhcp owns the /etc/dhcpd.conf file
  • dploy-dhcp doesn't include by default a non-existent /etc/dploy/dhcp.conf file

(Those post install script should become real scripts launched by all install means)

File size: 1.3 KB
Line 
1#
2# $Id$
3#
4
5Summary: dploy.org PXD interface tools
6Summary(fr): Outils d'interface PXD pour dploy.org
7
8Name: PBPKG
9Version: PBVER
10Release: PBTAGPBSUF
11License: GPL
12Group: PBGRP
13Url: PBURL
14Source: PBSRC
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
16BuildArch: noarch
17Requires: dploy-common, tftp-server, sudo, perl, syslinux, PBDEP
18
19%description
20PBDESC
21
22%description -l fr
23Outils d'interface PXE pour dploy.org
24
25%prep
26%setup -q
27
28%install
29%{__rm} -rf $RPM_BUILD_ROOT
30export DESTDIR=$RPM_BUILD_ROOT
31export PREFIX=%{_exec_prefix}
32export CONFDIR=%{_sysconfdir}/PBPROJ
33./install.sh
34
35%clean
36%{__rm} -rf $RPM_BUILD_ROOT
37
38%files
39%defattr(-,root,root)
40%doc ChangeLog
41#%doc INSTALL COPYING README AUTHORS NEWS
42%{_bindir}/*
43
44%post
45# Include dploy in sudoers
46grep -qE '^dploy ' %{_sysconfdir}/sudoers | grep /bin/umount
47if [ $? -ne 0 ]; then
48 echo 'dploy ALL=NOPASSWD: /bin/mount -o loop ?*' >> %{_sysconfdir}/sudoers
49 echo 'dploy ALL=NOPASSWD: /bin/umount ?*' >> %{_sysconfdir}/sudoers
50fi
51
52# Setup all required paths for tftpboot environment
53pathpxe=`grep pathpxe %{_sysconfdir}/PBPROJ/dploy.conf | cut -d= -f2`
54for p in $pathpxe $pathpxe/../mondorescue $pathpxe/../linuxcoe; do
55 if [ ! -d $p ]; then
56 mkdir -p $p
57 fi
58 chgrp dploy $p
59 chmod 775 $p
60done
61
62%changelog
63PBLOG
Note: See TracBrowser for help on using the repository browser.