Ignore:
Timestamp:
Jun 2, 2008, 7:11:23 PM (16 years ago)
Author:
Bruno Cornec
Message:
  • dploy-pxe requires syslinux (at least on rhel 5)
  • dploy-pxe adds permission to mount/umount iso images via sudoers
  • dploy-pxe now creates all required dirs under /tftpboot
  • dploy-dhcp owns the /etc/dhcpd.conf file
  • dploy-dhcp doesn't include by default a non-existent /etc/dploy/dhcp.conf file

(Those post install script should become real scripts launched by all install means)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • projects/dploy/pbconf/devel/dploy-pxe/rpm/dploy-pxe.spec

    r421 r470  
    1515BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
    1616BuildArch:      noarch
    17 Requires:       dploy-common, tftp-server, sudo, perl, PBDEP
     17Requires:       dploy-common, tftp-server, sudo, perl, syslinux, PBDEP
    1818
    1919%description
     
    4343
    4444%post
     45# Include dploy in sudoers
     46grep -qE '^dploy ' %{_sysconfdir}/sudoers | grep /bin/umount
     47if [ $? -ne 0 ]; then
     48    echo 'dploy ALL=NOPASSWD: /bin/mount -o loop ?*' >> %{_sysconfdir}/sudoers
     49    echo 'dploy ALL=NOPASSWD: /bin/umount ?*' >> %{_sysconfdir}/sudoers
     50fi
     51
     52# Setup all required paths for tftpboot environment
     53pathpxe=`grep pathpxe %{_sysconfdir}/PBPROJ/dploy.conf | cut -d= -f2`
     54for p in $pathpxe $pathpxe/../mondorescue $pathpxe/../linuxcoe; do
     55    if [ ! -d $p ]; then
     56        mkdir -p $p
     57    fi
     58    chgrp dploy $p
     59    chmod 775 $p
     60done
    4561
    4662%changelog
Note: See TracChangeset for help on using the changeset viewer.