source: ProjectBuilder/projects/uuwl/pbconf/devel/uuwl/rpm/uuwl.spec@ 1673

Last change on this file since 1673 was 1673, checked in by Bruno Cornec, 12 years ago

r5037@localhost: bruno | 2012-11-10 03:25:35 +0100

  • First successful RPM build of UUWL using now autoconf
File size: 1.4 KB
Line 
1#
2# $Id$
3#
4%define major 0
5%define libname %mklibname PBPKG %{major}
6%define develname %mklibname PBPKG -d
7
8Summary: PBSUMMARY
9Name: PBPKG
10Version: PBVER
11Release: PBTAGPBSUF
12License: PBLIC
13Group: PBGRP
14Url: PBURL
15Source: PBREPO/PBSRC
16#PBPATCHSRC
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
18Requires: kernel-devel
19
20%description
21PBDESC
22
23%package -n %develname
24Summary: Development files for %{name}
25Provides: %{name}-devel
26Requires: pkgconfig
27Requires: %{libname} = %{version}-%{release}
28
29%description -n %develname
30This package contains libraries and header files for
31developing applications that use %{name}.
32
33%package -n %{libname}
34Summary: Libraries for %{name}
35
36%description -n %{libname}
37The libraries for %{name}.
38
39%prep
40%setup -q
41
42%build
43%configure
44make %{?_smp_mflags}
45
46#check
47#make check
48
49%install
50%{__rm} -rf $RPM_BUILD_ROOT
51make DESTDIR=$RPM_BUILD_ROOT install
52
53%clean
54%{__rm} -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(-,root,root)
58%doc ChangeLog
59%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
60#INSTALL README
61
62%files -n %{libname}
63%defattr(-,root,root)
64%doc ChangeLog
65%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
66%{_libdir}/*.so*
67
68%files -n %{develname}
69%defattr(-,root,root)
70%doc ChangeLog
71%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
72%{_includedir}/*
73%{_libdir}/*.a
74%{_libdir}/*.la
75
76%changelog
77PBLOG
Note: See TracBrowser for help on using the repository browser.