source: ProjectBuilder/projects/uuwl/pbconf/devel/uuwl/rpm/uuwl.spec@ 1674

Last change on this file since 1674 was 1674, checked in by Bruno Cornec, 11 years ago

r5052@localhost: bruno | 2012-11-11 02:50:54 +0100

  • uuwl is now a meta package
File size: 1.5 KB
Line 
1#
2# $Id$
3#
4%define major 0
5%define libname %mklibname PBPKG %{major}
6%define develname %mklibname PBPKG -d
7
8Name: PBPKG
9Summary: PBSUMMARY
10Version: PBVER
11License: PBLIC
12Group: PBGRP
13Url: PBURL
14Release: PBTAGPBSUF
15Source: PBREPO/PBSRC
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
17Requires: %{develname} = %{version}-%{release}
18
19%package -n %develname
20Summary: Development files for PBPKG
21Provides: PBPKG-devel
22Requires: pkgconfig
23Requires: %{libname} = %{version}-%{release}
24
25%description
26PBDESC
27
28%description -n %develname
29PBDESC
30
31This package contains static libraries and header files for
32developing applications that use PBPKG.
33
34%package -n %{libname}
35Summary: Libraries for %{name}
36Requires: kernel-devel
37
38%description -n %{libname}
39PBDESC
40
41This package contains dynaic libraries for
42developing applications that use PBPKG.
43
44%prep
45%setup -q
46
47%build
48%configure
49make %{?_smp_mflags}
50
51#check
52#make check
53
54%install
55%{__rm} -rf $RPM_BUILD_ROOT
56make DESTDIR=$RPM_BUILD_ROOT install
57
58%clean
59%{__rm} -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(-,root,root)
63%doc ChangeLog
64%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
65#INSTALL README
66
67%files -n %{libname}
68%defattr(-,root,root)
69%doc ChangeLog
70%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
71%{_libdir}/*.so*
72
73%files -n %{develname}
74%defattr(-,root,root)
75%doc ChangeLog
76%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
77%{_includedir}/*
78%{_libdir}/*.a
79%{_libdir}/*.la
80
81%changelog
82PBLOG
Note: See TracBrowser for help on using the repository browser.