source: ProjectBuilder/projects/uuwl/pbconf/devel/uuwl/rpm/uuwl.spec@ 1681

Last change on this file since 1681 was 1681, checked in by Bruno Cornec, 11 years ago

r5099@localhost: bruno | 2012-11-28 16:14:05 +0100

  • Fix UUWL build (no Makfile filtering and adds delivery of fake sys includes)
File size: 1.6 KB
Line 
1#
2# $Id$
3#
4%define major 0
5%define libname %mklibname PBPKG %{major}
6%define develname %mklibname PBPKG -d
7
8Name: PBPKG
9Summary: PBSUMMARY
10Version: PBVER
11License: PBLIC
12Group: PBGRP
13Url: PBURL
14Release: PBTAGPBSUF
15Source: PBREPO/PBSRC
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
17Requires: %{develname} = %{version}-%{release}
18
19%package -n %develname
20Summary: Development files for PBPKG
21Provides: PBPKG-devel
22Requires: pkgconfig
23Requires: %{libname} = %{version}-%{release}
24
25%description
26PBDESC
27
28%description -n %develname
29PBDESC
30
31This package contains static libraries and header files for
32developing applications that use PBPKG.
33
34%package -n %{libname}
35Summary: Libraries for %{name}
36Requires: kernel-devel
37
38%description -n %{libname}
39PBDESC
40
41This package contains dynaic libraries for
42developing applications that use PBPKG.
43
44%prep
45%setup -q
46
47%build
48%configure
49make %{?_smp_mflags}
50
51#check
52#make check
53
54%install
55%{__rm} -rf $RPM_BUILD_ROOT
56make DESTDIR=$RPM_BUILD_ROOT install
57# Also install the fake compatibility include files
58%{__cp} -rp include/sys $RPM_BUILD_ROOT/%{_includedir}
59
60%clean
61%{__rm} -rf $RPM_BUILD_ROOT
62
63%files
64%defattr(-,root,root)
65%doc ChangeLog
66%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
67#INSTALL README
68
69%files -n %{libname}
70%defattr(-,root,root)
71%doc ChangeLog
72%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
73%{_libdir}/*.so*
74
75%files -n %{develname}
76%defattr(-,root,root)
77%doc ChangeLog
78%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
79%{_includedir}/*.h
80%{_includedir}/*/*.h
81%{_libdir}/*.a
82%{_libdir}/*.la
83
84%changelog
85PBLOG
Note: See TracBrowser for help on using the repository browser.