Opened 8 years ago

Closed 6 years ago

#117 closed defect (wontfix)

debian packages doesnt upgrade cleanly from 0.10 to 0.12

Reported by: Benoit Mortier Owned by: Bruno Cornec
Priority: minor Milestone: 0.12.6
Component: pb Version: 0.10.1
Keywords: Cc:

Description (last modified by Bruno Cornec)

Hello,

when upgrading my packages from 0.10 to 0.12i got this issue

Les paquets suivants seront mis à jour :
  libprojectbuilder-perl project-builder
2 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 234 ko dans les archives.
Après cette opération, 135 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
ATTENTION : les paquets suivants n'ont pas été authentifiés.
  libprojectbuilder-perl project-builder
Faut-il installer ces paquets sans vérification (o/N) ? o
Réception de : 1 ftp://ftp.project-builder.org/debian/ 6.0/contrib libprojectbuilder-perl all 0.12.1-1 [112 kB]
Réception de : 2 ftp://ftp.project-builder.org/debian/ 6.0/contrib project-builder all 0.12.1-1 [121 kB]
234 ko réceptionnés en 1s (186 ko/s) 
Reading package fields... Done
Reading package status... Done
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
(Lecture de la base de données... 315413 fichiers et répertoires déjà installés.)
Préparation du remplacement de libprojectbuilder-perl 0.10.1-1 (en utilisant .../libprojectbuilder-perl_0.12.1-1_all.deb) ...
Dépaquetage de la mise à jour de libprojectbuilder-perl ...
dpkg : erreur de traitement de /var/cache/apt/archives/libprojectbuilder-perl_0.12.1-1_all.deb (--unpack) :
 tentative de remplacement de « /usr/share/perl5/ProjectBuilder/Env.pm », qui appartient aussi au paquet project-builder 0.10.1-1
configured to not write apport reports
                                      dpkg-deb: sous-processus coller tué par le signal (Relais brisé (pipe))
Préparation du remplacement de project-builder 0.10.1-1 (en utilisant .../project-builder_0.12.1-1_all.deb) ...
Dépaquetage de la mise à jour de project-builder ...
Traitement des actions différées (« triggers ») pour « man-db »...
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libprojectbuilder-perl_0.12.1-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Change History (3)

comment:1 Changed 8 years ago by Bruno Cornec

Description: modified (diff)

comment:2 Changed 8 years ago by Bruno Cornec

Milestone: 0.12.20.12.3
Status: newassigned
Version: 0.12.10.10.1

Indeed the ENv.pm modules has been put lower in the tree, as used now by other scripts. I have however no idea how to indicate that in the deb package format :-( The rpm format doesn't exhibit the issue as long as you install the packages simultaneously (which is generally the case).

If you can provide guidance on how to perform that for Debian, that would be great.

Also for the omment, the change from 0.10 to 0.11 to 0.12 indicates a potential interface change (I'm not yet at 1.0 ;-)

comment:3 Changed 6 years ago by Bruno Cornec

Resolution: wontfix
Status: assignedclosed
Note: See TracTickets for help on using tickets.