Opened 3 weeks ago

Last modified 3 weeks ago

#177 assigned defect

newproj doesn't wrk anymore ?

Reported by: bruno Owned by: bruno
Priority: major Milestone: 0.15.2
Component: pb Version: 0.15.1
Keywords: Cc:

Description

When testing with a new project from scratch with nothing, just a setup in .pbrc.yml, we get:

pb -p python-formats -v -v newproj 
Using text interface with C locale
Entering pb_conf_init
PBPROJ = python-formats
DEBUG: pb_conf_add with $VAR1 = '/users/bruno/.pbrc.yml';

DEBUG: pb_conf_cache of /users/bruno/.pbrc.yml at position 0
Loading YAML conf file /users/bruno/.pbrc.yml
[...]
Loading YAML conf file /users/rpmbootstrap/.pbrc.yml
[...]
PBDEFDIR: /users/bruno/prj
DEBUG: Creating a non-volatile temporary directory (/tmp/pb.bjvfDc39DT)
PBTMP: /tmp/pb.bjvfDc39DT
DEBUG: pb_conf_get_in_hash_if on params pbprojdir
DEBUG: pb_conf_get_in_hash_if returns
$VAR1 = {
          'dploy' => '$ENV{\'HOME\'}/dploy.org/svn',
          'rinse' => '$ENV{\'HOME\'}/prj/rinse',
          'mondorescue' => '$ENV{\'HOME\'}/mondo/svn',
          'uuwl' => '$ENV{\'HOME\'}/prj/UUWL',
          'gosa' => '$ENV{\'HOME\'}/prj/gosa',
          'schroot' => '$ENV{\'HOME\'}/prj/schroot',
          'pusk' => '$ENV{\'HOME\'}/prj/PUSK',
          'ossi' => '$ENV{\'HOME\'}/prj/ossi',
          'linuxcoe' => '$ENV{\'HOME\'}/prj/LinuxCOE',
          'uggla' => '$ENV{\'HOME\'}/prj/python-redfish.uggla'
        };
WARNING: no pbprojdir defined, using /users/bruno/prj/python-formats
         Please create a pbprojdir reference for project python-formats in /users/bruno/.pbrc.yml
         if you want to use another directory
PBDESTDIR: /users/bruno/prj/python-formats/pbdelivery
PBBUILDDIR: /users/bruno/prj/python-formats/pbbuild
pb_vcs_compliant: envar: PBCONFDIR - defdir: /users/bruno/prj/python-formats/pbconf - uri: svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf
DEBUG: pb_conf_get_in_hash_if on params pbconfdir
DEBUG: pb_conf_get_in_hash_if returns
$VAR1 = {
          'pdfposter' => '$ENV{\'HOME\'}/prj/pdfposter/devel/pbconf',
          'python-formats' => '$ENV{\'HOME\'}/pb/projects/python-formats/pbconf',
          'uggla' => '$ENV{\'HOME\'}/prj/python-redfish.uggla/pbconf',
          'fossology' => '$ENV{\'HOME\'}/prj/fossology/pbconf',
          'ossi' => '$ENV{\'HOME\'}/pb/projects/ossi/pbconf',
          'python-tortilla' => '$ENV{\'HOME\'}/pb/projects/python-tortilla/pbconf',
          'pb' => '$ENV{\'HOME\'}/pb/pbconf',
          'mondorescue' => '$ENV{\'HOME\'}/pb/projects/mondorescue/pbconf',
          'python-redfish' => '$ENV{\'HOME\'}/prj/python-redfish/pbconf'
        };
PBCONFDIR: /users/bruno/pb/projects/python-formats/pbconf
DEBUG: uri:svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf
DEBUG: scheme:svn+ssh ac: host:svn.project-builder.org port: path:/prj/svn/pb/projects/python-formats/pbconf
Checking out svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf
pb_vcs_mod_socks returns svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf
pb_vcs_mod_htftp returns svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf
Checking out svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf to /users/bruno/pb/projects/python-formats/pbconf ... Executing svn co svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf /users/bruno/pb/projects/python-formats/pbconf
ERROR: child (svn co svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf /users/bruno/pb/projects/python-formats/pbconf) cwd=/users-ssd/bruno/pb/projects exited with value 1
svn: E170000: L'URL 'svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf' n'existe pas
ERROR running command (svn co svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf /users/bruno/pb/projects/python-formats/pbconf) with cwd=/users-ssd/bruno/pb/projects, pid=19050
pb_vcs_compliant end
DEBUG: uri:svn+ssh://svn.project-builder.org/prj/svn/pb/projects/python-formats/pbconf
DEBUG: scheme:svn+ssh ac: host:svn.project-builder.org port: path:/prj/svn/pb/projects/python-formats/pbconf
WARNING: no pbroot defined, using /users/bruno/pb/projects/python-formats/pbconf
         Please use -r release if you want to use another release
PBROOTDIR=/users/bruno/pb/projects/python-formats/pbconf
Unable to create /users/bruno/pb/projects/python-formats/pbconf/python-formats.yml at /usr/lib/perl5/vendor_perl/5.22.3/ProjectBuilder/Env.pm line 400.

Change History (1)

comment:1 Changed 3 weeks ago by bruno

  • Status changed from new to assigned

Some improvements with [2407] and previous patches, but still not fully solved

Note: See TracTickets for help on using tickets.