Opened 10 years ago

Closed 9 years ago

#56 closed defect (fixed)

Repository for deb based distribution should provide a Release file

Reported by: bruno Owned by: bruno
Priority: major Milestone: 0.10.1
Component: pb Version: 0.9.8
Keywords: Cc:

Description

This would allow more easy integration with upstream deb distributions, by providing an Origin tag usable when packages are provided both upstream and by the distro. (Cf: https://sourceforge.net/mailarchive/message.php?msg_name=3E131A21E348654BAED17074816567DE5CB233EBDC%40GVW1163EXB.americas.hpqcorp.net)

Attachments (1)

buildrepo (1.8 KB) - added by joachim 9 years ago.
Script to build repository for multi binary packages with release files for each architecture

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by bruno

  • Owner set to bruno
  • Status changed from new to assigned

Also cf: http://www.debian.org/doc/manuals/repository-howto/repository-howto and http://www.debian.org/doc/manuals/apt-howto/ch-apt-get.fr.html#s-pin

Implementing this feature may require to reorganize repository with an arch subdir !

comment:2 Changed 9 years ago by bruno

  • Milestone changed from 0.9.9 to 0.9.10

comment:3 Changed 9 years ago by bruno

  • Milestone changed from 0.9.10 to 0.9.11

comment:4 Changed 9 years ago by joachim

Further on the current solution is not able to handle mutli binary packages. Therefore we use the attached script to build up repositories which solves your problem also.

May be it helps you solving the issue above and multi binary issue in pb.

Changed 9 years ago by joachim

Script to build repository for multi binary packages with release files for each architecture

comment:5 Changed 9 years ago by bruno

The arch subdir has been introduced in rev [1080] as a first step.

comment:6 Changed 9 years ago by bruno

I attempted to fix the issue you reported with rev [1112]. Could you please report if the debian repository I generated using that new version at ftp://ftp.project-builder.org/test/debian/ is now correct for a apt usage ?

Thanks in advance.

comment:7 Changed 9 years ago by joachim

I've used the provided pb.sources.list and aptitude says:

Feh ftp://ftp.project-builder.org 5.0/contrib Packages

Kann Datei nicht holen, Server antwortete: »Failed to open file. «

Hole:9 ftp://ftp.project-builder.org 5.0/contrib Sources Feh ftp://ftp.project-builder.org 5.0/contrib Sources

Kann Datei nicht holen, Server antwortete: »Failed to open file. «

But I cannot say why. The only difference I've found related to my repository is the position of the Contents-*.tar.gz file. My is directly under dists/5.0 and not under contrib and I've check it right now, apt-file looks for it at dists/VERSION. But I don't think, thats the main problem with the created repo.

comment:8 Changed 9 years ago by bruno

I've fixed the Contents issue with rev [1121]. Thanks for your check.

As for the issue you have I think maybe the pb.sources.list is wrong:

$ more pb.sources.list 
deb ftp://ftp.project-builder.org/test/debian/5.0 5.0 contrib
deb-src ftp://ftp.project-builder.org/test/debian/5.0 5.0 contrib

I think that the version shouldn't be there in the URL no ? (after http://www.debian.org/doc/manuals/apt-howto/ch-basico.en.html)

So I made a new patch (rev [1122])for this as well, thinking it is the cause of the problem. (I had previously just one level to remove, but with the arch in place now, I have 2 levels to remove).

Could you please test again for the 2 issues ? TIA.

comment:9 Changed 9 years ago by bruno

Have you had time to check the proposed fix ? I'd like to release the next stable version and would like to have that bug fixed in it.

comment:10 Changed 9 years ago by joachim

It worked with the lines:

deb ftp://ftp.project-builder.org/test/debian 5.0 contrib and the same as deb-src. This fits also the scheme deb URL_TO_DISTS_DIR VERSION_OR_VERSION_NAME REPO_TYPE.

comment:11 Changed 9 years ago by bruno

  • Resolution set to fixed
  • Status changed from assigned to closed

Ok so my last revision indeed fixed it. Thanks for your report, will be in 0.10.1.

Note: See TracTickets for help on using tickets.