Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#72 closed enhancement (invalid)

Call createrepo instead of yum-arch

Reported by: joachim Owned by: bruno
Priority: major Milestone: 0.10.1
Component: pb Version: 0.10.1
Keywords: Cc:

Description

May it be possible to call createrepo instead of yum-arch to build yum-repositories? I use it, for ferdora and opensuse repos, because I build them on debian and yum-arch is not available, but createrepo is (debian package is called also createrepo).

Change History (3)

comment:1 Changed 8 years ago by bruno

In fact yum-arch is called first, to create the headers structure, and then createrepo is called just after to create the xml based infos.

The scrip tis:

# Clean up old repo content
rm -rf headers/ repodata/
# Create yum repo
yum-arch .
# Create repodata
createrepo .

Does it cause a problem for you if the yum-arch command is unavailable ? I can test that it's executable before calling it.

comment:2 Changed 8 years ago by joachim

  • Resolution set to invalid
  • Status changed from new to closed

ok, I must try it again, because I thought it wasn't working, but it can be something else. I also thought createrepo is a replacement of yum-arch, which is wrong either.

Though, I will close it and reopen it again, if i have made sure, that the trouble was caused by missing yum-arch

comment:3 Changed 8 years ago by joachim

A, I think to remember, that createrepo wasn't installed, so this might was the problem. If you check that also, you can leave it as invalid.

Note: See TracTickets for help on using tickets.