source: ProjectBuilder/projects/uuwl/pbconf/devel/uuwl/rpm/uuwl.spec@ 1681

Last change on this file since 1681 was 1681, checked in by Bruno Cornec, 11 years ago

r5099@localhost: bruno | 2012-11-28 16:14:05 +0100

  • Fix UUWL build (no Makfile filtering and adds delivery of fake sys includes)
File size: 1.6 KB
RevLine 
[1475]1#
2# $Id$
3#
[1476]4%define major 0
5%define libname %mklibname PBPKG %{major}
6%define develname %mklibname PBPKG -d
[1475]7
[1674]8Name: PBPKG
[1475]9Summary: PBSUMMARY
10Version: PBVER
11License: PBLIC
12Group: PBGRP
13Url: PBURL
[1674]14Release: PBTAGPBSUF
[1475]15Source: PBREPO/PBSRC
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
[1674]17Requires: %{develname} = %{version}-%{release}
[1475]18
[1476]19%package -n %develname
[1674]20Summary: Development files for PBPKG
21Provides: PBPKG-devel
[1476]22Requires: pkgconfig
23Requires: %{libname} = %{version}-%{release}
[1475]24
[1674]25%description
26PBDESC
27
[1476]28%description -n %develname
[1674]29PBDESC
[1476]30
[1674]31This package contains static libraries and header files for
32developing applications that use PBPKG.
33
[1476]34%package -n %{libname}
35Summary: Libraries for %{name}
[1674]36Requires: kernel-devel
[1476]37
38%description -n %{libname}
[1674]39PBDESC
[1476]40
[1674]41This package contains dynaic libraries for
42developing applications that use PBPKG.
43
[1475]44%prep
45%setup -q
46
47%build
[1673]48%configure
[1475]49make %{?_smp_mflags}
50
[1476]51#check
52#make check
53
[1475]54%install
55%{__rm} -rf $RPM_BUILD_ROOT
56make DESTDIR=$RPM_BUILD_ROOT install
[1681]57# Also install the fake compatibility include files
58%{__cp} -rp include/sys $RPM_BUILD_ROOT/%{_includedir}
[1475]59
60%clean
61%{__rm} -rf $RPM_BUILD_ROOT
62
63%files
64%defattr(-,root,root)
65%doc ChangeLog
[1476]66%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
67#INSTALL README
[1475]68
[1476]69%files -n %{libname}
70%defattr(-,root,root)
71%doc ChangeLog
72%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
[1673]73%{_libdir}/*.so*
[1476]74
75%files -n %{develname}
76%defattr(-,root,root)
77%doc ChangeLog
78%doc LICENSE_LGPL-2.1 LICENSE_MIT AUTHORS
[1681]79%{_includedir}/*.h
80%{_includedir}/*/*.h
[1673]81%{_libdir}/*.a
82%{_libdir}/*.la
[1476]83
[1475]84%changelog
85PBLOG
Note: See TracBrowser for help on using the repository browser.