Opened 10 years ago

Closed 7 years ago

#42 closed defect (fixed)

cross architecture VEs

Reported by: bryang Owned by: bruno
Priority: major Milestone: 0.12.1
Component: pb Version: 0.9.6
Keywords: Cc:

Description

It seems there is an issue when using VE (like for an i386 VE on an x86_64 platform), that the uname -m returns that for the running kernel, which yields issues for PB and it's auto-detection and naming routines.

Change History (11)

comment:1 Changed 10 years ago by bruno

  • Owner set to bruno
  • Status changed from new to assigned

comment:2 Changed 10 years ago by bruno

This seems to be a rinse error, where after extracting everything with the i386 arch correctly, then rinse calls yum, but yum updates with x86_64 packages :-(

comment:3 Changed 10 years ago by bruno

  • Milestone changed from 0.9.7 to 0.9.8

comment:4 Changed 9 years ago by bruno

  • Milestone changed from 0.9.9 to 0.9.10

Needs to be checked with rpmbootstrap

comment:5 Changed 9 years ago by bruno

  • Milestone changed from 0.9.10 to 0.9.11

This problem is also happening with rpmbootstrap. I'll work on a fix for this case, at least for this combination.

comment:6 Changed 9 years ago by bruno

An approach would be to force the nature of the distribution we are working with in some cases where it could be useful (LSB build in a non detected LSB env, or windwos build in a Linux VM, or change of arch like here).

The issue is now when to force it, and still benefiting from the automagic detection, which is so useful.

comment:7 Changed 8 years ago by bruno

  • Milestone changed from 0.10.1 to 0.10.2

comment:8 Changed 8 years ago by bruno

  • Milestone changed from 0.11.3 to 0.11.4

comment:9 Changed 8 years ago by bruno

  • Milestone changed from 0.12.1 to 0.12.2

comment:10 Changed 7 years ago by bruno

  • Milestone changed from 0.12.2 to 0.12.1

The recent addition of setarch usage in pb code may help solving that for 0.12.1

comment:11 Changed 7 years ago by bruno

  • Resolution set to fixed
  • Status changed from assigned to closed

This is now solved in the beta of 0.12.1 thanks to Eric Andersson's efforts.

Note: See TracTickets for help on using tickets.