Ignore:
Timestamp:
Jun 4, 2008, 4:42:52 PM (16 years ago)
Author:
Bruno Cornec
Message:

moving post install from %post to a dedicated external perl script

File:
1 edited

Legend:

Unmodified
Added
Removed
  • projects/dploy/pbconf/devel/dploy-pxe/rpm/dploy-pxe.spec

    r470 r476  
    1515BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
    1616BuildArch:      noarch
    17 Requires:       dploy-common, tftp-server, sudo, perl, syslinux, PBDEP
     17Requires:       dploy-common, dploy-pxelinux, tftp-server, sudo, perl, PBDEP
    1818
    1919%description
     
    4141#%doc INSTALL COPYING README AUTHORS NEWS
    4242%{_bindir}/*
     43%{_mandir}/man1/*
    4344
    4445%post
    45 # Include dploy in sudoers
    46 grep -qE '^dploy ' %{_sysconfdir}/sudoers | grep /bin/umount
    47 if [ $? -ne 0 ]; then
    48     echo 'dploy ALL=NOPASSWD: /bin/mount -o loop ?*' >> %{_sysconfdir}/sudoers
    49     echo 'dploy ALL=NOPASSWD: /bin/umount ?*' >> %{_sysconfdir}/sudoers
    50 fi
    51 
    52 # Setup all required paths for tftpboot environment
    53 pathpxe=`grep pathpxe %{_sysconfdir}/PBPROJ/dploy.conf | cut -d= -f2`
    54 for p in $pathpxe $pathpxe/../mondorescue $pathpxe/../linuxcoe; do
    55     if [ ! -d $p ]; then
    56         mkdir -p $p
    57     fi
    58     chgrp dploy $p
    59     chmod 775 $p
    60 done
     46%{_bindir}/dploy-pxe-post
    6147
    6248%changelog
Note: See TracChangeset for help on using the changeset viewer.